Support » Plugin: Smush - Compress, Optimize and Lazy Load Images » Multivendor Woocommerce problem

  • Resolved nivsp

    (@spektorniv)


    I am using Dokan plugin on top of Woocommerce to create a multivendor marketplace.
    After installing your plugin, vendors can’t upload images anymore, they don’t have permission.
    Tried to use User Roles Editor plugin to see if it is a simple matter of permissions but I couldn’t resolve the issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hello @spektorniv

    I hope you’re well!

    Can you tell me, please

    – if it it applies to all existing vendors or just some of them?
    – how big (in terms of file size and image dimensions) such images are?
    – are you using any other image optimization tools (such as e.g. built-in into Jetpack plugin)?

    Also, are there any error messages besides the “no permission” warning?

    I’m asking about that because I just installed Dokan (free version) on a fresh WordPress sites with default WooCommerce in order to test it but with a newly created “vendor” role account I was able to upload cover image and product images without any problems. Therefore, I’d like to gather a bit more information about this specific case so we could further investigate it and find solution.

    Looking forward to hear from you,
    Adam

    Thank you for trying to help.

    I am using Dokan Pro version.
    – applies to all vendors
    – tried with various sizes
    – not using any other image optimization tool
    – no other optimization tools

    I tried on an instance that smush was not installed on and after installation everything works fine. Can it be something with the fact that I activated Smush Pro and then canceled it?

    Apart from this difference, both environments are identical

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @spektorniv

    Hope you’re doing well!

    Would you please remove the current Smush plugin and re-install the free version again?

    If the issue still persists, please see if it is still happening when only Smush and Dokan plugins are active. Just in case, please have a site’s backup before deactivating all plugins, so you could restore the site if something will go wrong.

    I’m afraid the Dokan version you’re using is a premium one and we do not have access to it to test it with a Smush plugin.

    Let us know how it went!

    Cheers,
    Nastia

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello there @spektorniv,

    Trust all is well!

    We’ve not heard from you in a while. I’ve marked this ticket as resolved for now, but if you need anything else at all, we’re here for you, please just reopen the ticket or create a new one.

    Have a good day!

    Cheers,
    Nastia

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Multivendor Woocommerce problem’ is closed to new replies.