Support » Plugin: Conditional Fields for Contact Form 7 » Multisteps buttons not working on PRO

  • Resolved cmhdesign

    (@cmhdesign)


    I am currently working on a multi step form using your conditional fields pro plugin as well as CF7 Smart Grid Design Extension.

    I was able to get the whole setup working and the sections divided as I wanted but the previous and next step buttons aren’t working. Even if I fill all the fields, when I click “next” nothing happens. Both buttons show as active as well instead of the “previous” one showing a muted color as in the examples on the documentation.

    I am unsure what to do to get it to work. I can send you the code or link to the page via email.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jules Colle

    (@jules-colle)

    could you give it a shot with the grid plugin disabled? There have been reported several problems with both plugins working together

    Thread Starter cmhdesign

    (@cmhdesign)

    ok, tested it out and created a new form without the grid and deactivated and reactivated plugins one by one.

    You are right that even the form that wasn’t grid enabled didn’t work as soon as I reactivated the grid plugin.

    Is there a fix for this? Or another grid plugin that works well with your multisteps? I have some repeaters and groups and those worked fine.

    Plugin Author Jules Colle

    (@jules-colle)

    None that I’m aware of, sorry.

    Thread Starter cmhdesign

    (@cmhdesign)

    Ok, will there be? Is it something that might be worked on? Just want to know if I can keep that idea in my back pocket for the future or if I should move on and try something else.

    Thanks.

    Plugin Author Jules Colle

    (@jules-colle)

    I’m not going to work on compatibility with any other plugins apart from Contact Form 7. That said, I’m always ready to implement code changes and will consider adding additional hooks if other plugin authors request them. So if the author of the grid plugin can hand me the solution, I’d be happy to implement it.

    In fact there’s an upcoming change in the pipeline that will improve compatibility with the Smart Grid plugin, this will not solve your problem, but just to illustrate that the author seems to be actively working on compatibility with other plugins, so there’s a good change it will get fixed.

    Thread Starter cmhdesign

    (@cmhdesign)

    Thank you so much for your time and help, I will open a ticket with them in case they have insight on it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Multisteps buttons not working on PRO’ is closed to new replies.