Support » Networking WordPress » multisite working but wp-admin 500 Internal Server Error

  • Resolved aldoemilio

    (@aldoemilio)


    I installed a fresh multisite (sub directory type) and created 3 sub – sites. The sites are accessible, but not the wp-admin of any of them. I got a 500 Server Error.
    The error in the log is:
    syntax error, unexpected '=' in /usr/local/lib/php.ini on line 842
    I checked in the cPanel forums. Corrected the issue but still getting the 500 error.

    The .htaccess reads:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) wp/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ wp/$2 [L]
    RewriteRule . index.php [L]
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

Viewing 5 replies - 1 through 5 (of 5 total)
  • The server error log now reads:
    Request exceeded the limit of 10 internal redirects due to probable configuration error. Use LimitInternalRecursion to increase the limit if necessary. Use LogLevel debug to get a backtrace., referer: http://domain.com/en/

    Changing the .htaccess to the following solved the problem:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Solved!

    Thank you for this, your final fix to htaccess helped me!

    error log file error code
    =========================
    [19-Jun-2013 10:25:46 America/New_York] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20100525/timezonedb.so’ – /usr/local/lib/php/extensions/no-debug-non-zts-20100525/timezonedb.so: cannot open shared object file: No such file or directory in Unknown on line 0

    error log file error code
    ==========================

    i am unable to access the wp-admin/

    this is my htaccess file code
    RewriteEngine On
    RewriteBase /web/
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    any pls help me out

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘multisite working but wp-admin 500 Internal Server Error’ is closed to new replies.