Support » Networking WordPress » Multisite with top-level domain issue after 3.1 upgrade

  • Resolved cwhebert


    Hey Folks,

    Prior to upgrading to 3.1 we had been able to run our blog network by choosing to add sites/blogs at the domains top-level ( or the sub-domain level ( I assume that of the 40 or so blogs on the network greater than 30 of them were added at the domains top level.

    Since the upgrade the ability to add a site at the top domain level has been eliminated. I am assuming there is a file that needs to be tweaked, or a setting that I am missing, or a plugin that went rogue and am looking for some help figuring it out.

    Any assistance you can provide would be appreciated.


Viewing 15 replies - 1 through 15 (of 15 total)
  • I closed your other post, no need to cross post between forum subsections.

    You need to ugrade the domain mapping plugin. that’s what gives you top level domains.


    I upgraded the plugin, but the site no longer acts the same way as it did before.

    Previous to the WordPress upgrade, our network under the Super Admin settings had a way for us to add a site or a blog. A site was a top-level domain and a blog was a sub-domain to the network.

    We have 8 blogs out of 40+ that were set-up as a subdomain and mapped to the bloggers purchased domain. Nearly all were added as a top-level domain using the “add site” link under the Super Admin tab. Now when adding a site either as a Network Admin or a Site Admin, we are only able to create sub-domains to the blog that we are currently in.

    I am completely lost here and have a back-log of about 5 bloggers waiting to get their sites added. Our previous workflow may have been incorrect, but it appears that the only way to get a top-level domain now, is to add a site as a sub-domain and map the url to it, and this is different than what our abilities were before.


    Did you have a network plugin that maybe you were using before? Becasue there never was the ability (built in) to add a top-level domain.

    When it was wpmu, if you were adding a “site” it was actually what is now called a network. so check and see if you were/are using our old multi-site plugin.

    Look in hte mu-plugins folder.

    Looking in the mu-plugins folder I am not seeing the multi-site plugin. I do however see multiple plugins created by our development firm, nothing resembling multi-site though.

    The terminology, multi-site, does sound familiar, unfortunately can’t say for sure. If it is called a network now, why am I not seeing an option for creating a network?

    I really appreciate your help in this matter. I would go back to the developer who helped build this platform, unfortunately, they are booked and not willing to look into this for us as quickly as needed.


    Can you list the folders/files in your mu-plugins folder?

    Sure here they are:


    I am an idiot I think…as I began typing these I see a single .php file labeled “multi-site-manager.php”…I assume that’s what was being refferenced?

    The above are folders, there are a dozen or more single .php files residing in the directory as well. Not sure I need to list those now…LOL

    So what help can you all offer now?


    as I began typing these I see a single .php file labeled “multi-site-manager.php”…I assume that’s what was being refferenced?


    You need an updated version of that plugin, which is the multi-network plugin.


    The plugin is behind the wall at it appears? Am I not able to get the update if I am not a member of the site? Why would a developer use a plugin like that and not tell his client that in order to maintain the plugins he needs a membership to a site?

    Of course I am not sure that the plugin actually exists behind their wall and makes me nervous to buy the membership for a plugin upgrade that may or may not exist.


    Am I not able to get the update if I am not a member of the site? Why would a developer use a plugin like that and not tell his client that in order to maintain the plugins he needs a membership to a site?


    Well. That was … a dick move of them. The dev, not WPMU. No, you cannot get the update unless you are a member.

    but there *are* alternatives.

    and of course you probably won;t be able to do a flat-out replacement…

    Are you sure you looked at the plugin details at the top of the plugin file?


    The detail information at the top of the plugin is listed below….

    Plugin Name: MU Multi-Site
    Plugin URI:
    Description: Adds a Sites panel for site admins to create and manipulate multiple sites.
    Version: 0.0.9
    Author: David Dean
    Author URI:

    The plugin URL, has an FAQ page where it states that to get the latest version of the plugin to go to WPMUDEV.

    I would love to know if my current workflow for adding blogs is flawed using this plugin anyway?


    Andrea, the networks for wordpress worked. I looked at the php file for the plugin itself and the code was very similar to the MU Multi-Site plugin. Did some more reading and it Networks for WordPress is teh replacement.

    Ipstenu & Andrea, THANK YOU VERY MUCH!

    Ipstenu: I promise it wasn’t my move to wall in anything at WPMUDev. This ancient plugin was posted there when it was free and open. I was as pissed as anybody when it switched from an open repository for WPMU plugins to a membership service.

    FWIW, there are no updates at WPMUDev. I don’t even have access to my own files that were posted there. The FAQ on the plugin homepage listed in the plugin header has info on the replacement.

    PS: sorry to hijack this thread; it came up as a referrer and I wanted to make sure people have the right info, since it is apparently still being referenced.

    David Dean – That’s really good to know, and I retract my ‘dick move’ comment. Thank you for the clarification and please accept my apology for a snap judgement.

    Are you saying they KEPT your plugin without giving you any access to edit/remove it? o.O

    Ipstenu – it’s cool. No hard feelings.

    I don’t know whether they still distribute the plugin (it wouldn’t be much use now anyway), but I don’t have access to edit or remove it. One day my account worked to edit, the next it wasn’t recognized and the plugin appeared as a “WPMU DEV Free Download.” Now it’s just a redirect to their sign up page.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Multisite with top-level domain issue after 3.1 upgrade’ is closed to new replies.