Support » Networking WordPress » Multisite with parked domain at root

  • I have a WordPress Multisite set up with my main domain name (let’s call it mysite.com), and I have another domain name as a parked domain which is pointed to the main web root (it’s just the main domain name with a different TLD, let’s call it mysite.net).

    Currently WordPress runs on the main domain and any URL using the parked domain redirects to the signup page. Is there any way I can tell WordPress to treat any URL using the parked domain as if it were the equivalent URL on the main domain? So if I went to mysite.net I would see the main site (the same as mysite.com), and site1.mysite.net would be the same as site1.mysite.com.

    Am I missing something really simple?

    Thanks

    Rhiannon

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Great, thanks!

    I’ve installed the plugin, and ticked ‘User domain mapping page’ in the settings, but I’m not seeing a domain mapping page anywhere in the individual site dashboards. What am I missing?

    There’s also no list of sites in the Settings>Domains section of the Network Admin dashboard. But by making a guess as to my site ID I’ve been able to set it up. Thanks!

    I’m still curious as to why the user domain mapping page isn’t showing up.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    If you want to make your site IDs visible in the network admin, try this: http://tech.ipstenu.org/hacks/site-id-columns-multisite/

    As for why it’s not showing up in the site dashboards… I don’t know. Did you network activate the plugin?

    Thanks for that. I’ve put the site id columns script into mu-plugins, but nothing seems to have changed: there’s no site id column in the sites list in the Network Admin. What’s supposed to happen?

    Yes, I did network activate the domain mapping plugin.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    It shows up in /wp-admin/network/sites.php

    Check your screen options, though it SHOULD be checked by default.

    It’s not showing up in /wp-admin/network/sites.php – the columns I have are:

    Domain
    Last Updated
    Registered
    Users
    Mapping

    My screen options doesn’t show it either.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Go to /wp-admin/network/plugins.php?plugin_status=mustuse

    Is the site ID plugin listed there?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Multisite with parked domain at root’ is closed to new replies.