Support » Plugin: Advanced Access Manager » MultiSite warning (minor bug and fix) in v. 6.4.0

  • Resolved SpeedOfLike

    (@speedoflike)


    First, thanks for the great work on the plugin. I just updated a multisite to v. 6.4.0 and WP started throwing the error:

    “Warning: count(): Parameter must be an array or an object that implements Countable” in line 100 of aam/application/service/core.php

    Looks like you accidentally tried to use count twice on the same variable, once on line 98 and once on 100:

    98 $blog_count = count($wp_admin_bar->user->blogs);
    99
    100 if (count($blog_count) > 0 || current_user_can(‘manage_network’)) {

    As soon as I removed the extra count() on 100, the error went away.

    If anyone else is experiencing the problem, line 100 should read:

    if ($blog_count > 0 || current_user_can(‘manage_network’)) {

    Thanks again for the great work!

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘MultiSite warning (minor bug and fix) in v. 6.4.0’ is closed to new replies.