WordPress.org

Forums

[resolved] Multisite w/ Domain Mapping & Dedicated IP - Godaddy (17 posts)

  1. fjrichman
    Member
    Posted 4 years ago #

    I'm trying to get Domain Mapping setup for my multisite so blog users can use their own domains.

    It all seems to be working fine except for a single fatal flaw.

    I'm trying to map http://www.thoughtsofthemasses.com/fjrichman to http://destruir.net/

    I took all the steps added the IP to the domain to point it, mapped the domain to the site with a plugin. But now that whole blog maps to the main blog. If I remove the mapping /fjrichman becomes usable, but with the mapping enabled it redirects to the main blog.

  2. Which plugin are you using to translate the wordpress stuff?

  3. fjrichman
    Member
    Posted 4 years ago #

    A plugin I found in a torrent of wordpress plugins, called Domain Mapping, it's a WPMUDev plugin, but I can't get help there because of the subscription fee I can't afford. Was hoping someone here could point me in the right direction.

  4. This is the one you want:

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

    It works exactly like the one on wordpress.com,. minus the payment part. And here's instructions:
    http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

    This one also prevents you from accidentally mapping a domain to the main site.

  5. fjrichman
    Member
    Posted 4 years ago #

    Okay, switched plugins, and the http://www.destruir.net still points to the main blog. However now /fjrichman/ is usable despite mapping.

    Any ideas?

  6. Make sure the old plugin was completely UNinstalled. this means look at the db and remove the old tables.

  7. fjrichman
    Member
    Posted 4 years ago #

    I dropped all domain mapping tables and let the plugin recreate them. I added destruir.net to the Domain mapping for /fjrichman/ and I guess now we wait and see, so far it still redirects to the main blog.

  8. Make sure you follow all the steps I linked to exactly. Something's not done right.

    The plugin handles the interface & login cookies.

    the actual mapping part is server setup and DNS redirection. The plugins *can't* do that for you, neither can wordpress.\

    So... .gotta make sure you're telling it where to go properly. ;)

  9. fjrichman
    Member
    Posted 4 years ago #

    I set the Domain to point here it's the only ARecord in the domain.
    ARecord @ 72.167.134.212

    Where the IP is the dedicated IP for my server.

  10. fjrichman
    Member
    Posted 4 years ago #

    I tried switching to subdomains (since having a dedicated IP allows that now) by enabling it in the config and manually changing the sites. But now interestingly enough whenever I try to go to http://destruir.net it takes me to the make a new site page with destruirnet being the subdomain for the new site.

  11. fjrichman
    Member
    Posted 4 years ago #

    I'm beginning to think the issue here is with the plugin/settings. Because the site clearly knows what domain I'm trying to use because it tries to treat it as a subdomain, so the question is, where's the problem and how can I fix it?

    I have an A Record pointing at the dedicated IP and a CNAME pointed at fjrichman.thoughtsofthemasses.com I have the domain mapped in the plugin to that blog, yet it refuses to actually show that blog when I visit the domain. Where is this acting up?

  12. I have an A Record pointing at the dedicated IP and a CNAME pointed at fjrichman.thoughtsofthemasses.com

    It's the CNAME pointed at the subdomain addreass. Don't. When you map it, that address will no longer exist.

    It's *either* an A record *or* a CNAME.

    And on your webhost end, you need a serveralis for the mapped domain to the originating domain of the install. Which Otto went over in his post.

  13. fjrichman
    Member
    Posted 4 years ago #

    After several hours of banging my head against the proverbial wall, the issue was the simple fact that the define for SUNRISE was the very last line in the config.

    Sorry to cause so many problems, it's working now :)

  14. Oh, you mean under the "stop editing here" line? ;P

    Yeah. That'd do it.

  15. JoshCork
    Member
    Posted 4 years ago #

    I'm having the same issue with a Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

    What's interesting is that this only occurs on domains that I have registered with GoDaddy.

    I have two Domains:
    1. Ubervoyant.com --> Registered with 1and1, hosting with GoDaddy
    2. iUpgrade.me --> Registered with GoDaddy, Hosted with GoDaddy.

    If you browse to ubervoyant.com the desired behavior is present.
    If you brows to iUpgrade.me I get the err:310 too many redirects

    Both of these domains are pointed at the same WordPress Multisite install. Both are set up the same way in domain mapping.

    Any ideas? The A Record for iUpgrade.me at GoDaddy is pointed at my IP address.
    Thanks in advance for any help!
    Josh

  16. JoshCork
    Member
    Posted 4 years ago #

    Okay, I fixed the issue I was having. As it turns out something was techinically wrong with the iUpgrade.me site that was set up in MultiSite. I deleted the site from the multisite install and then reinstalled it and wham... working!

  17. JoshCork
    Member
    Posted 4 years ago #

    Turns out that deleting it was not the solution. Instead i had a case issue. The Multisite Redirect Domain Mapping issue was solved using the right case for my domain names! I explain in detail on my blog (along with a video of the fix) if you are interested (linked above).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.