Support » Plugin: SendGrid » Multisite: Updated to 1.10.1, now I can’t set up SendGrid for subsites

  • Resolved ArkonLabs

    (@arkonlabs)


    Previous to the recent SendGrid plugin that “added” multisite support (introduced in 1.10.0), I was able to enable the SendGrid plugin per subsite and was able to configure SendGrid’s sender email on each subsite.

    After I updated, I was forced to network activate the plugin, which I knew I would have to do since i read the changelog… but what the changelog didn’t mention was that we are now limited to configuring SendGrid’s settings from the Network site’s dashboard for the entire multisite.

    I have multiple clients and each client has a subsite, and each subsite uses a different SendGrid account.

    Do I need to downgrade to a previous version? Why was it not mentioned that this update would remove functionality?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author SendGrid INC

    (@team-rs)

    Hi,

    Currently the Multisite is in beta and it includes the requested changes from the users.
    We are sorry that this is not what you expected but in the description is mentioned that

    we are now limited to configuring SendGrid’s settings from the Network site’s dashboard for the entire multisite.

    Thank you,
    SendGrid

    I assumed this meant that I’d be able to manage all of the subsites in the multisite from the Network site’s dashboard, similar to how Jetpack allows us to manage subsites from their Network site dashboard.

    I think the wording is a bit misleading.

    Plugin Author SendGrid INC

    (@team-rs)

    Hello ArkonLabs,

    Thank you for the suggestions. We will do some research in our side and we’ll enhance the plugin to cover more multisite features.

    Thank you,
    SendGrid

    Thank you, please keep us updated.

    Hello Arkon Labs,

    Same issue and concerns for us.

    We are still using 1.9.5 due to these reasons.

    Plugin Author SendGrid INC

    (@team-rs)

    Hi all,

    Please check the latest version of our plugin. We did some major improvements on multisite side (including the possibility of having SendGrid settings page on every subsite of the network).

    We would love to hear your feedback,
    SendGrid

    Thank you for fixing this! I’ve now updated all of my sites to the latest version and it seems to be working great! I’ll be sure to leave a five star review!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Multisite: Updated to 1.10.1, now I can’t set up SendGrid for subsites’ is closed to new replies.