WordPress.org

Forums

multisite subsite dashboard redirects to log-in (1 post)

  1. kcirtap
    Member
    Posted 2 years ago #

    Currently have an issue with a fresh install of multisite as a subdomain network on my local MAMP. The main site is functional, although any subsequent subsite that I create is not. When I create a subsite I can visit the site, but I have no dashboard access. Selecting dashboard redirects to the log-in (which does not allow Super Admin user access). In other words -- no back end here.

    Have explored variations of my hosts file, and Apache httpd-vhosts.conf without success.

    What I am trying to do is install a multisite subdomain network on my local host (MAMP) for development to match the functioning multisite subdomain network on my live host. If necessary, I will switch to the subdirectory network for live and local but want to see if this can be resolved first.

    Am I wrong to think I can setup a multisite subdomain network on my localhost? I understand that a subdirectory network on localhost is a no-brainer, but this is not what I want. I have read through a multitude of tutorials around setting up a multisite subdomain, although I have not heard of anything relating to this issue of no dashboard access.

    Three things I am uncertain about that may relate to the issue:
    1) I am confused about "blogs.dir". Is it necessary to create this directory within wp-content? I have heard yes, and no on the topic. I am running 3.5.1 and think this is a non issue.
    2) Should my main url include a TLD to allow the subdomain network to work? Currently, it is "example". Should I change this to "example.dev"?
    3) My current configuration is in question -- specifically how I have entered httpd-vhosts.conf (Please offer corrections if any):

    MAMP:
    Ports: Apache port 80, MySQL Port 8889 (unsure if this should be 3306)
    Apache: Set to root directory

    Mac hosts file:
    127.0.0.1 example
    127.0.0.1 site1.example

    MAMP/conf/apache/httpd.conf -- virtual hosts uncommented:
    # Virtual hosts
    Include /Applications/MAMP/conf/apache/extra/httpd-vhosts.conf

    MAMP/conf/apache/extra/httpd-vhosts.conf:
    NameVirtualHost *:80

    <VirtualHost *:80>
    DocumentRoot "/Users/username/Documents/SITES"
    ServerName localhost
    </VirtualHost>

    <VirtualHost *:80>
    DocumentRoot "/Users/username/Documents/SITES/example/wordpress"
    ServerName example
    ServerAlias *.example *.site1.example
    <Directory "/Users/username/Documents/SITES/example/wordpress">
    AllowOverride All
    </Directory>
    </VirtualHost>

    This is probably something simple and overlooked as usual, but I am stuck in the mud and fishing for answers.

    Thank you in advance for feedback.

Topic Closed

This topic has been closed to new replies.

About this Topic