Support » Networking WordPress » Multisite subdomains not resolving

  • Resolved CallMeAndy

    (@callmeandy)


    Subsites and subsite admin-pages are not working out.
    I’ve done this before on older version and followed through the directions http://codex.wordpress.org/Create_A_Network
    to make sure it was fresh in my mind and that nothing had changed – well in fact I then had to follow it over and over to make sure of each step as I have clearly failed to do something correctly. As subdomains were first getting the server not found error, although one of which has, since my adding and subsequently removing wildcard subdomain in cPanel, switched to 404 errors.

    The setup is on an Add-on domain. Swithced from a standalone install and disabled all plugins.

    Any thoughts very welcome now as I am running out of hair?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The difference I assume BTW between the two test subdomains is that I created a specific subdomain in cPanel for the one with the 404 result, as opposed to the “server not found” with no cPanel subdomain setup.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    What do the 404s look like? Are they cpanel 404s or do they match the main site of your network?

    On cPanel you SHOULD just need to have the wildcard subdomains and then everything gets properly kicked to /public_html/

    Hi Mika thanks for taking a look at this,
    Well in fact i have left it alone since I put up the post but now I have
    on revisiting earlier I had:
    abods.virtualenergy.co.uk showing the Index of message and one folder the cgi_bin (for this one I setup a subdomain on cPanel)

    and on test.virtualenergy.co.uk I still had the Server Not Found. message. The 404 was not presented in a site template if that’s what you mean, not apparently generated by the site.

    Since then I have just put back the *.virtualenergy.co.uk

    abods.virtualenergy.co.uk is now redirecting to http://whateverok.com/wp-signup.php?new=abods.virtualenergy.co.uk
    (whateverok.com is another account on the same Hostgator-babycroc hosting account)

    abods.virtualenergy.co.uk is still on Server not found, but whatsmydns is not showing it as having propagated anywhere as yet!

    After the dust settled, presumably some affect of DNS propagation, both abods.virtualenergy.co.uk and test.virtualenergy.co.uk are getting ‘Server not found’ and not sure which I should be checking but both A and CNAME search on whatsmydns are showing ALL unresolved.

    I have removed the subdomain that I set up explicitly for abods.virtualenergy…

    and I have put the wildcard subdomain provision in place. *.virtualenergy.co.uk

    Perhaps I am not explaining this very well. I am still getting “Server Not Found”

    So at Hostgator the main domain is whateverok.com

    I have an Addon domain virtualenergy.co.uk the creating process of which creates a sub-domain virtualenergy.whateverok.com as the default.

    I am trying to setup my network of sites on a Sub-domains basis.
    As per the codex and @ipstenu advice above, wildcard DNS for on-demand domain-based sites is required and is in place. At least to say the was specified by using an *, i.e *.virtualenergy.co.uk on Document Root /public_html

    Sometime ago, granted on an earlier version of wordpress on this same main domain, I setup a multisite on adventurebods.whateverok.com This worked without issue although three months back I converted to a single site basis. With that site I never used the wildcard method at all, at least I am pretty sure I didn’t, and in fact I never setup any sub-domains at all in cPanel.

    Since runing into this problem I have tested multisite on the maindomain: whateverok.com, and as per the problem described above I am unable to access a test site’s dashboard or the test site’s home page due to “Server Not Found”

    I don’t know if it tells us anything or not, but I notice a difference between the two implementations. When in the admin dashboards of virtualenergy I can see MySites dropdown exposes the test subsites. In whateverok I cannot see the test subsite in the dropdown or at all on the mainsite My Sites page, it is only evident on network admin on sites page, not on the dropdown.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Dude. Andy, don’t bump. Some of us volunteers have lives that keep us busy. If you’re that desperate, you’ll want to go to jobs.wordpress.net and hire someone.

    https://www.whatsmydns.net/#A/adsasdas.virtualenergy.co.uk

    You don’t have wildcard DNS.

    Appogies Mika It wasn’t intended as a bump, I thought the silence meant I hadn’t communicated the problem well enough. As regards going to jobs I am afraid I will have to be patient, as I’m afraid I cannot even afford the lightbulb for the bathroom at the moment! So at your own pace and Thanks for your patience.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I deleted merper’s posts which made no sense.

    If you can’t afford expertise then you’ve got to learn to be patient with the moments of free time folks get :/

    Anyway, your issue remains that you do not have wildCard DNS set up.

    You should fix that. Check with your domain registrar and webhost.

    I’m not sure why you are saying wildCard DNS is not setup?

    I ‘bumped’ as you put it because I felt I had not explained something clearly. Now that seems even more evident.

    virtualenergy.co.uk points to hostgator nameservers and has done for years there seems no problem here. Why are you referring me then to the the registrar?

    As I said in the clarification “bump” *.virtualenergy.co.uk has been configured at hostgator and points at /public_html directory

    Have I done something wrongly here?

    Edit: I since spoke with hostgator support who, perhaps incorrectly, edited the directory to public_html/virtualenergy.co.uk I would tend to think Mika knows what he is taking about on this!, however support has verified that wildcard DNS was setup correctly other than that, but he also sees that it is not resolving and has escalated, citing vhost configuration on the server as being possibly in error….awaiting response on that.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Totally and fully off topic but here goes.

    I ‘bumped’ as you put it because I felt I had not explained something clearly. Now that seems even more evident.

    When someone posts something that makes you reply

    “Pardon me, my good person? Could you explain that in more detail? I don’t believe I follow what you’re saying and can use some clarification.”

    Or something along those lines, then that’s not a “bump”. Those are fine. 😉

    When you reply merely to get your topic bumped up on the page and don’t add anything substantive then that’s a bump. Those get deleted as they do not accomplish anything useful.

    Back to our regularly scheduled support topic:

    Wildcard DNS entries are to get the URL to your multisite. So when you put in something-anything.your-domain.com and you get a reply from your Multisite installation, then that’s good. That means DNS is doing it’s god which is to get visitors to your front door.

    If your multisite replies along the lines of “That site does not exist” that’s alright.

    If you get 404 error pages from something else, such as your host or cPanel then that may mean DNS is working but your host is intercepting your wildcard URLs before they get to your multisite.

    Mika is correct: you do not have a wildcard record setup properly.

    On a Linux ssh session I can type this command.

    $ dig *.virtualenergy.co.uk
    
    ; <<>> DiG 9.8.3-P1 <<>> *.virtualenergy.co.uk
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 58533
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;*.virtualenergy.co.uk.		IN	A
    
    ;; AUTHORITY SECTION:
    virtualenergy.co.uk.	10800	IN	SOA	ns6449.hostgator.com. dnsadmin.gator3225.hostgator.com. 2015031501 86400 7200 3600000 86400

    I did not get an answer for *.virtualenergy.co.uk which I should have. I don’t mind what the answer is exactly but I received no answer.

    My own DNS zone as an example, it looks like this.

    $ dig *.dembowski.net
    
    ; <<>> DiG 9.8.3-P1 <<>> *.dembowski.net
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61531
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;*.dembowski.net.		IN	A
    
    ;; ANSWER SECTION:
    *.dembowski.net.	1800	IN	CNAME	baloo.dembowski.net.
    baloo.dembowski.net.	1800	IN	A	209.20.89.108

    The CNAME answer isn’t really important, what’s important is that I received an answer that directs a user’s browser to my IP address.

    Yours is not setup and needs to be.

    Thanks Jan, so this was never about my not having done what I was supposed to, but rather that for whatever reason the process had not had the desired outcome. Well as mentioned in last post that hopefully will now be resolved as hostgator have escalated the issue.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Well as mentioned in last post that hopefully will now be resolved as hostgator have escalated the issue.

    Cool. And if you use that dig command you can validate that it’s really fixed too. 😉

    Hi Guys yes thanks – finally resolving. not sure what jigory/pokery was worked by the host – but either way thats the first issue sorted. Now I have a whitescreen problem however so will start another post.

    Thanks again.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Multisite subdomains not resolving’ is closed to new replies.