Support » Networking WordPress » Multisite subdomain doesn't work after i add new

  • Hello,

    My host company is Justhost, After I add a new site to network subdomain of site doesn’t work.

    Here what I did step by step:

    – I bought a new domain name lets say its ab123.com
    – Added that new a.com domain to my old b123.com domain’s public_html folder from CPanel.
    – Installed WordPress manually ro root folder (public_html)
    – Added necessary code in config file included network engine.
    – Created my network, selected subdomain option and added necessary codes to htaccess file and config file.
    – Relogged to panel
    – I can see Super Admin part in Admin panel
    – I went to Websites and added new site test.abc123.com and I can see it in websites. In list its there.
    – I have received e-mail and details.
    Until here everything OK

    My main page works but When I enter to test.abc123.com subdomain site there is not such an address. It looks like didn’t create the subdomain.

    I am sure I didn’t do anything wrong at steps. But It’s not working.

    Also my htaccess file:

    # -FrontPage-
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName b123.com
    AuthUserFile /home/b/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/b/public_html/_vti_pvt/service.grp
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    How can I fix this issue?

    Regards,
    E.K.

Viewing 15 replies - 1 through 15 (of 31 total)
  • + I forgot to say that I have created blogs.dir directory with 755 permission under wp-content

    one more update,

    Forwarded subdomain * .ab123.com to public_html via Cpanel

    still doesnt work

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Wildcard subdomains are normally set for the root domain on your web account. Not for add-on domains.

    If you switched the main domain, the host also needs to switch things on their end, so the wildcard subdomain record in Apache (where you can;t get to) can also be changed.

    Thanks for answer Andrea.
    But what things?
    What can I do to fix this? I can ask to hosting company change stuff but I don’t know what should I ask them.

    Could you be more specific please? Then I ll write to my hosting company for changes.

    Regards.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Ask them what domain the wildcard subdomain is set for, and tell them the new domain you want it to work on.

    I’m having this same problem, but my domain never changed. What could be wrong?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Ask your host if wildcard subdomains are set.

    this is the same problem i am having and have been having for a couple or months, i checked with my host (justhost) and they confirmed the wildcard subdomain is set correctly on the root domain. Any ideas n e 1???

    thanks in advance

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    is your installation in the root domain? Did you ad the wildcard dns record? Can you leave a link so we can ping it

    my install is in the root http://mrcherry.co.uk , i added wildcard dns . Everything was working perfectly and then i suddenly went wrong

    thankyou andrea

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    http://foobar.mrcherry.co.uk/ doesn’t seem to work at all.

    Did you point wildcard DNS to your public_html folder?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Doing a ping or an nslookup on your domain still says the wildcards aren’t set up. Talk to your host. if it was working and suddenly not, and you didn’t do anything… then it’s them.

    And yes, even a routine update on the server may have wiped out the Apache record.

    The wildcard subdomain *.mrcherry.co.uk has been properly recreated and pointed to your public_html/
    > But you should note that domain mrcherry.co.uk points to 3rd party nameservers, and that is the exact place where the A record for subdomain * should be added, please contact support of ns and ns2.hosteurope.com ans ask them to add wildcard subdomain record

    this is the response from just host

    the domain name is at 123-reg and just host is my server. i have a cname record pointing to my domain so i wonder if what he is saying is correct ??

    ive just tried to create a subdomain through my cpanel but i get the same result as when i do it virtually via wordpress

    i am certain it is a server side problem but it seems i may need help to diagnose it and baby-feed them the solution.

    the resulting page also notes that it is a dns error
    >>
    Sorry, the page you were looking for cannot be found

    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.
    Error: (DNS), click the back button to try another link.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Multisite subdomain doesn't work after i add new’ is closed to new replies.