The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

multisite subdomain can't login in IE reauth=1 (cookies) (5 posts)

  1. arhit
    Posted 4 years ago #

    Hi, I am experiencing a problem with login in internet explorer - multisite subdomain install.

    I have a fresh 3.3 multisite install on a domain, no plugins what-so-ever ce.si

    A test user login information is (just a subscriber acc):

    I am trying to login with IE 8 (Slovenian version) and it doesn't work, hovever FF, Chrome, work without problems. I tried also from another computer, IE doesn't login.

    IE changes url to: http://ce.si/wp-login.php?redirect_to=http%3A%2F%2Fce.si%2Fwp-admin%2Fprofile.php&reauth=1
    and it doesn't login. Seems like cookies are not beeing created.

    The funny thing is, that if I change in my wp-config.php:

    define( 'SUBDOMAIN_INSTALL', true );
    define( 'SUBDOMAIN_INSTALL', false );

    it starts working (but i want subdomains).

    <history of the IE bug>
    I have the same problem on a different host on a different domain on an slightly older version of WordPress. As it is very irritating for users, as they are not able to login, I've decided to recreate scenario on different host, just to see if it is the host problem, but it looks like it isn't. As the older site runs on vps on one host, this fresh test version is just on a reseller cpanel based account on different host provider.

    I have two A records:

    CPANEL subdomains:
    domain ce.si and subdomain *.ce.si are routed to folder where wordpress is installed. (basepath)

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('WP_DEBUG', false);

    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'ce.si' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    I would be super-grateful if someone can point me to the solution.
    Please try to login in IE and give me feedback of the version of IE you use and if the login is successfull.

  2. If I had IE, I would.

    Honestly, that you've had the SAME problem on older WP but only with IE makes me think... it's not IE. If it was, people would be screaming murder right now (like all those corp. wage slaves who use WordPress).

    Are these clean installs with no plugins?

    Are they on the same server?

  3. arhit
    Posted 4 years ago #

    Thank you Ipstenu for reply.

    it is a fresh installation, without any plugins.

    It is probably not a server problem, 2 servers are placed 100 milles away from each other, both in Slovenia, but different hosting providers managing them.

    I've seen couple of posts of people with similar problems, but you are right, it can't be a general problem. I am thinking that it might be either UTF-8 or language related (even though it sounds weird).

    We use đšžćč and similar letters in Slovenia and also IE comes in Slovenian language. I suspect it is to blame, but not sure.

    So I kindly ask again any Windows user from anywhere else but Slovenia to try to log on with INTERNET EXPLORER on the test account:


    Thank you!

  4. arhit
    Posted 4 years ago #

    Update: I just came across a coworker that has English IE... Login doesn't work in the english version... So i am in the dark again...
    any ideas?

  5. blackriver
    Posted 3 years ago #

    Cookies from subdomains will be blocked by the IE "medium" privacy setting.

Topic Closed

This topic has been closed to new replies.

About this Topic