Multisite subdomain 404 when user logged in (9 posts)

  1. snewby
    Posted 2 years ago #

    I am setting up a multi-site implementation for a site and I am just about to wrap it up.

    This bug is interesting, the situation follows:

    1. User is logged in
    2. User has created subdomain
    3. User attempts to go to mysite.domain.com
    4. Request results in 404

    If anonymous user accesses mysite.domain.com, it works without issue.

    wildcard domain is setup on host properly.

    Permalinks are different from main to subdomain ~ which might be the difference.

  2. A 404 is an interesting problem. How is it formatted? Like your server's 404 or like WP's?

  3. snewby
    Posted 2 years ago #

    The 404 is coming back as WP, with my theme wrapping it, not the host 404.

    Strange that it only happens when the user is logged in, and works perfectly fine when there is no user logged in or admin is logged in.

  4. Which theme? The main site or the subsite?

    And do you have any caching running?

  5. snewby
    Posted 2 years ago #

    It is the theme of the subsite, yes I am running Quick Cache. I will try tonight to turn that off and see if the that is causing the issue.


  6. snewby
    Posted 2 years ago #

    I turned off quick cache, and installed 404 error monitor plug-in on the site. Same result, monitor picked up up, but didn't tell me anything.

  7. What other plugins are running network wide?

    And what's in your .htaccess?

  8. snewby
    Posted 2 years ago #

    htaaccess file contents...

    # Use PHP5CGI as default
    AddHandler fcgid-script .php
    # BEGIN s2Member GZIP exclusions
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteBase /
    	RewriteCond %{QUERY_STRING} (^|\?|&)s2member_file_download\=.+
    	RewriteRule .* - [E=no-gzip:1]
    # END s2Member GZIP exclusions
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    all sorts of plugins...
    advanced custom fields
    profile builder
    user role editor
    role scoper
    wp show ids
    google analytics
    gravity forms
    import users from csv
    export users to csv
    online back up for wordpress
    quick cache
    really simple captcha
    store locator plus
    wordpress SEO

  9. Well... My GUESS is one of your user managment plugins is doing it :/ It makes the most sense.

Topic Closed

This topic has been closed to new replies.

About this Topic