WordPress.org

Forums

[resolved] Multisite set-up (28 posts)

  1. Abaris
    Member
    Posted 3 years ago #

    I already installed the network option using the instructions.I am pretty sure that I did everything right ( including the wild card fron cpanel, created one sub domain..).Still when accessing WP, I can see the sites, I can edit and post content in pages, but when I want to view any page, I get the following mesage. " Greeting Site Administrator!You are Currently allowing "none" registrations. To change or disable.....".
    The only thing I am not sure is if the site address ( with www.) was set up the same for WP durring the instalation ( and I do not know hoe to check that)
    Whe I type the URL for the sub domain ( homefinder.magicdesign.ca)it open a generic page on my Host.
    Thank you for your time and help.

  2. derrick_w
    Member
    Posted 3 years ago #

    In http://codex.wordpress.org/Before_You_Create_A_Network, as of Mar '13, it stated "If you have www in the settings for your domain URL, and plan to use subdomains for multisite, make sure that both the site address and the WordPress address are the same. If you plan on changing them to domain.com or http://www.domain.com, do so before you begin the rest of the setup for multisite, as changing the domain name after the fact is more complicated."

    One way to take a look at your Single site paths without going into the WP db is in wp-config
    define('MULTISITE', false); # use to FLIP between Single and Network
    Then login to the Site Admin dashboard and go to Settings -> General
    I think you can change paths there, and this should update the wp_options table, which is used in Single mode. But editing the Network tables will be required to 'fix' a miss step in preparing for Network install.

    Post back when you have tested your main Single site for correct operation, posts, permalinks, media. Then we'll tackle the Network details.

  3. derrick_w
    Member
    Posted 3 years ago #

    Let me add, I can't remember, but I believe the Network install won't let you choose subdomains if www precedes your domain.tld. If that is true, it is probably best to set up your Single site to paths as domain.tld and have URL Rewrite permanently move calls for http://www.domain.tld to domain.tld.

  4. Abaris
    Member
    Posted 3 years ago #

    Thank you Derrick
    It seems that this is the problem. The site address is set as http://www.magicdesign.ca and WP address for the Primary site is http://magicdesign.ca. I have no clue how this can be fix. Is any way to go back to the network install?
    Thank you.

  5. Abaris
    Member
    Posted 3 years ago #

    Thanks to Derrick I can access now the Primary site and is working fine. I changed both address to www. ( site and WP)
    I cannot access the sub domain yet?? (homefinder.magicdesign.ca)

  6. derrick_w
    Member
    Posted 3 years ago #

    We can benefit from your feedback, as specific as you can make it, to points in previous posts. Things like steps taken? things changed? In what config is your site now?

    In this recent topic http://wordpress.org/support/topic/1360840 you will find answers.

    Short version is set path and domain correctly in wp_blogs table. In your case I'll guess path / and domain magicdesign.ca
    and in wp-config
    define('DOMAIN_CURRENT_SITE', 'magicdesign.ca'); # no trailer slash, overrides db.wp_site.domain
    define('PATH_CURRENT_SITE', '/'); # overrides db.wp_site.path

  7. Abaris
    Member
    Posted 3 years ago #

    Setting MULTISITE to false and going back to Single site allowed me to access Setings/General and set both WP and Site to the same URL : http://www.magicdesign.ca. The same was showing in wp-config.(define('DOMAIN_CURRENT_SITE','www.magicdesign.ca');
    I can use the WP in the Single site OK.
    Once I change back to multisites, the subdomain site is no longer accesible.
    I cannot find the wp_blogs table.
    I guess it is true that a little bit of knowledge is more dangerous that no knowledge at all.

  8. derrick_w
    Member
    Posted 3 years ago #

    Where did you look for wp_blogs table? Were there parts of the topic I linked to previously that you could not understand? Set your .htaccess or web.config file as read only.

  9. Abaris
    Member
    Posted 3 years ago #

    Looking into the Database:
    wp_site shows id 1, domain http://www.magicdesign.ca, path / (rows 0)??
    wp_blogs blog id1 ,site id 1 http://www.magicdesign.ca ,path /
    blog id5 ,site id 1 homefinder.magicdesign.ca ,path /
    wp_sitemeta : meta id 14
    siteurl : http://www.magicdesign.ca/
    So far everything looks as it should be, i think.
    I do not know how to set .htaccess or web.config as read only.
    It may worse to mention that both installs ( primary site and the subdomain) are new, without any content.
    I would like to find out how to fix this, but it may be easyer to reinstall WP alltogether??

  10. derrick_w
    Member
    Posted 3 years ago #

    Is this forum misrepresenting what you intend to post. I know it adds 'http://' to strings it thinks are URLs as in this next one http://www.magicdesign.ca converting it to a link Whereas this next one I enclosed in 'code' tags www.magicdesign.ca If the domain strings you posted above are as they appear in the db, remove the http;// part and any trailing slashes /

    You can continue to allow WP to write your URL Rewrite rules, but you might want to learn file permissions and how to change them. Goes to file security later on. Post your .htaccess or web.config. That file should be in the root directory.

    Let me know if you'd rather 'start over' and I'll suggest alternatives to completely reinstalling WP.

  11. Abaris
    Member
    Posted 3 years ago #

    Thank you Derrik.
    I appreciate very much that you are spending all this time to help me.
    the .htaccess file has the following inside:

    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    It seems that is way more complicated to fix this mistake then I tought. I do not really know hou far the solution is.You may suggest if it is faster and easyer to start over or to continue. I am affraid that even deliting and reinstalling require some "special knowledge". At this point I am not sure anymore that the network part of a new installation with selection of the proper URL path will not bring me back to the same point.
    What is your oppinion.
    Thank you.

  12. derrick_w
    Member
    Posted 3 years ago #

    I wish you had confirmed the paths in the database I asked for above. I am assuming they did not contain http:// and to me all the WP Network requirements look satisfied.

    Time for me to tell you what I tested, cause I think you need your webhost's help.
    Request: http://www.magicdesign.ca/index.php
    Result: WP answers as expected, except I see plugins being loaded. Disable all plugins for troubleshooting.
    DNS: www host reached via CNAME record

    Request: homefinder.magicdesign.ca/index.php
    Result: Internal Server Error
    DNS: I think dns is the problem for the subdomain site, NOT WP. I also used 3rd party dns tools, and got eerors

    Request: homefinder.magicdesign.ca/ (asking for default doc by not specify one)
    Result: Your webhost's content??

    Let's see if you hosting provider can help you. Let us know.

  13. Abaris
    Member
    Posted 3 years ago #

    Thank you again Derrick
    I removed the http:// and / from siteurl in the database (wp_sitemeta) and just de-activated all the plugins.
    I do not have any answer from the Host yet.
    I will keep you posted.
    Excellent attitude, Thank you very much. I start to belive that all my trouble was for my gain.
    Happy Easter!!!

  14. derrick_w
    Member
    Posted 3 years ago #

    Thank you, I should have checked the basic DNS earlier.

    Two things while we wait to hear from your host:
    1) enable the plugins that interpret the 'shortcodes' that now show on the main site
    2) I must have mislead you regarding the wp_sitemeta.siteurl field. Different than the others we covered, it should be http://www.magicdesign.ca/

  15. Abaris
    Member
    Posted 3 years ago #

    Hello Derrik,
    This is the answer from my Host:
    "Unfortunately, because this is third-party code we cannot go through and debug it for you, since we do not provide scripting/coding support.
    We, at Bluehost.com, provide support for server and server-performance related issues and basic installation and removal of scripts. We regrettably do not support scripting tutorials on third party installations, or debugging of websites. We suggest contacting a web developer or a programmer who can give you personalized support. I apologize for any inconvenience."
    Nice! I do not even know what to answer back.
    Thank you again for your kind support.
    All the Best!.

  16. derrick_w
    Member
    Posted 3 years ago #

    Hold on, maybe they are right. Let's step outside of WP. Create test.html page with the following code:

    <!DOCTYPE html><html><head><title>HTML5 Title</title>
    <meta name="description" content="Page description here" />
    <meta charset="UTF-8" /></head><body><h2>Subdomain DNS working</h2></body></html>

    and place it on the root of homefinder.magicdesign.ca

    Then try accessing it, http://homefinder.magicdesign.ca/test.html

    If it works we'll take another look at url rewriting & WP.
    If it doesn't, you can try again with your provider, without mentioning WP.

  17. derrick_w
    Member
    Posted 3 years ago #

    Are we in Network mode, as in wp-config has define('MULTISITE', true) and the other lines? If not, reenable Network mode. Now, can you get into Network admin? If so go to Settings -> Network Setup. If the .htaccess settings are there, repost them. If they don't show then repost your .htaccess.

  18. Abaris
    Member
    Posted 3 years ago #

    Hello Again!
    I reposted the .htaccess
    wp-config looks OK ( wp_debug is set to false???, all the rest are TRUE)
    I can access Network Admin. but i cannot open the Dashboard or any other features of homefinder.magicdesign.ca, so I canet make the TEST. It just open the JustHost 404.

  19. derrick_w
    Member
    Posted 3 years ago #

    I'm confused. We are not concerned with getting into Site admin of homefinder, yet. Did you get into Network admin -> Settings -> Network Setup? In there, did you see the .htaccess settings or not? If you can't get into Network admin -> Settings -> Network Setup, it probably won't help to repost your .htaccess.

  20. Abaris
    Member
    Posted 3 years ago #

    Yes Derrik, I can access Network Admin, and I copied the .htaccess settings and reposted, as you suggested.

  21. Abaris
    Member
    Posted 3 years ago #

    his is the .htaccess on file now:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

  22. derrick_w
    Member
    Posted 3 years ago #

    .htaccess looks good for WP. You skipped over the suggestion above. Secondly, in your hosting configuration, can you confirm the default document settings for

    homefinder.magicdesign.ca

    ? Try adding this line
    DirectoryIndex index.php index.html index.htm
    to your .htaccess above and outside of the WP section.

  23. Abaris
    Member
    Posted 3 years ago #

    I cannot figure out what exactly I skupped. I did follow all the sugestions to the best of my abbility.
    I added the line to the TOP of the .htaccess file.
    I do not see any change yet.

  24. Abaris
    Member
    Posted 3 years ago #

    This is how .htaccess looks now:

    DirectoryIndex index.php index.html index.htm

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

  25. Abaris
    Member
    Posted 3 years ago #

    You also mentioned " in your hosting configuration, can you confirm the default document settings for homefinder.magicdesign.ca" I do not know how to do it.

  26. derrick_w
    Member
    Posted 3 years ago #

    default document settings would be between you and your hosting provider. The webserver for
    homefinder.magicdesign.ca just displayed this:

    Index of /
        400.shtml
        401.shtml
        403.shtml
        404.shtml
        500.php
        500.shtml
        cgi-bin/
        default.html
        favicon.ico
        test.txt
    Apache Server at homefinder.magicdesign.ca Port 80

    What I can tell you from the above, is that homefinder.magicdesign.ca and www.magicdesign.ca are pointed at two different physical locations, folders. All your subdomains must arrive at the same folder with the same WP index.php before WordPress can have a chance at delivering the content you expect it to.

    We also know now that the DNS is OK, or at least it was when I got the index of files you see above.

    Sorry I can't help you with your hosting. You need to study more yourself, or talk your hosting provider into helping you, or talk a friend into helping you out, or you need to hire some tech help with a little WP experience.

  27. Abaris
    Member
    Posted 3 years ago #

    Thank you very much Derrick for your time and patience.
    I had the chance to learn a lot from you and I am grateful for that.
    I guess I have to keep learning.

  28. howarddrive
    Member
    Posted 3 years ago #

    this is an awesome post Abaris

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.