Support » Alpha/Beta/RC » Multisite problems with RC3

  • I have just installed a fresh multisite installation to compare it with my other multisite installation where I had problems with the image file upload paths after upgrading from an earlier wp 3.0 version to RC3.

    In went through all necessary steps but the permalinks don’t seem to work.

    After creating a new site test I am getting an email that the site has sucessfully set up (still I cannot access it) and in addition a new user was created with the name of the new site together with a password.

    This is a completely fesh installation and my feeling is that something is messed up with the multisite feature.

Viewing 15 replies - 1 through 15 (of 24 total)
  • I also am having problems creating new sites with a 3.0 multisite intstall. The process seems to go well on the “add site” screen, the email is sent and the site is added to the list. But visiting the site produces a database connection error, and clicking the “Backend” link takes me to the main site Dashboard, as if the new site were not there. I saw a new user created the first couple times I tried this, but after deleting those blogs & trying again, my most recently created ghost-site has only me listed as a user.

    Checking the databases, I can see an entry in the wp_blogs table for the new site, but not any other tables associated with that site’s blog_id.

    Also, the emails I received were blank where they should have listed “Site URL:”

    Which kind of site did you pick, subdomains or subfolders?

    I’m on a subfolder install, thus: http://readingcirclebooks.com/testie.

    Try it with no plugins active.

    *Sigh* I knew you’d say that.

    With 43 recently active plugins,* http://readingcirclebooks.com/testie2/ is up and running in a jiffy.

    Reactivating in small batches, starting w/ the sitewide tags…

    [*Yes, I know I’m an addict.]

    All right, the Sitewide Tags plugin has created – apparently without a hitch – a new blog, http://readingcirclebooks.com/aleph, to aggregate my posts across the network, so that I can feature some of them on a new home page using your Featured Posts plugin. This also seems to be working, though there’s nothing in the sitewide feed yet except the “Hello World” post.*

    So it looks like the RC3 multisite functionality is fine for my subfolder install at least. I’ll let you know if the problem returns as I reactivate the plugins.

    *Will that fix itself, or does it only aggregate going forward, which would mean I have some importing to do?

    Hmm – fortunately, but somewhat uselessly, the problem has not returned as I reactivated the plugins. So I’ve no clue as to the cause. :-/

    Sitewide tags only aggregates going forward, it doesn’t go pick up old posts.

    I *think* there may be a one-time script out there in the mu forums, but my memory is fuzzy on that one….

    And *headdesk* on non reproducible problems. 😀

    I am having this same problem. When I create a new site through the “register” link, the site and user are created, the email is sent, but neither the link from the activation page nor the link from the email work. The “Site not found on this server” message” shows up.

    The same thing happens if I create the site from inside the admin panel.

    3.0 was installed this morning on a test site, and no new plugins or themes have been installed. I am using Twenty Ten as the theme.

    I had this same problem yesterday on a site that was upgraded from 2.9.2, so decided to try a brand new install.

    Thanks in advance for the help!

    That isn’t exactly the same issue other people were having.

    Go to Super Admin -> Sites. Add a new site. Visit the site. can you see it? No? Then the server is not set up.

    What format did you pick, subdomains or subfolders? If you picked subdomains, did you do the necessary wildcards in Apache and DNS like ti says?

    It was set up with subfolders. This problem was corrected by properly placing the ht access file. Thank you for your help!

    Hi!!,
    Has anyone tried the RC3 with multisite activated with subdomains?
    I’ve installed RC3, I followed the steps that come in different websites (wp-config.php edit, create .httaccess file, enable it in the admin, and create a site with a subdomain in the superadmin page.

    If I have my main website and tell http://sample.com WP 3 RC3 to add another site in http://blog.sample.com, what are the next steps?
    do I create the subdomain in my control panel Domain server?
    do i redirect the folder where the subdomain?
    and now do I have to install in my supposed new folder a new version of WP 3 RC3 or already installed by itself (or virtually…)

    thanks in advance

    I answer myself, the site is automatically created, you must create the subdomain in the control panel Domain server, and point to the direction of principal site.

    thanks for the web

    @ mucky

    I also have installed RC3 with multisite and subdomains

    I did not have to use the control panel of the server as it will create them automatically – although to work it out took a while and great help from the forums 😀

    Did you create the wildcard alias? Also wondering about the ServerAlias in the http.conf file. I just ask as that is not in your list of things that you did.

    http://mu.wordpress.org/forums/topic/18258?replies=11 is where I got it to work – and also I put links there that may help others having the same problems. Good Luck!

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Multisite problems with RC3’ is closed to new replies.