[resolved] Multisite Problem with Umlaut Domain (3 posts)

  1. tgruendl
    Posted 1 year ago #

    Hi all,

    I migrated a WordPress Multisite installation from an non-umlaut domain to an umlaut domain.

    The main blog works, I can enter the dashboard, the files are all there, the theme fits, everything works.

    But the subsites do not work. When going the main page of a subsite, I get redirected to the apache default server page. When I try to enter the dashboard of a subsite, I get a 404.

    It looks like the .htaccess rewrite doesn't work for subsites, but I can find no error in there.

    The domain is blog.teamspiel-├╝ben.de

    This is my apache config:
    <VirtualHost blog.xn--teamspiel-ben-5ob.de>
    ServerName blog.xn--teamspiel-ben-5ob.de
    ServerAlias *.blog.xn--teampspiel-ben-5ob.de
    DocumentRoot /var/www/blogs/blog.teamspiel-uben
    ErrorLog /var/www/logs/blog.teamspiel-uben.log
    DirectoryIndex index.php index.html
    <Directory /var/www/blogs/blog.teamspiel-uben>
    Options ExecCGI FollowSymLinks -Indexes
    AllowOverride all
    Order allow,deny
    Allow from all

    The .htaccess is the standard wordpress 3.8.1 generated htaccess when installing.

    Has somebody encountered a similar problem and solved it?

    Right now I am lost as where I could look further.

    Kind Regards,


  2. tgruendl
    Posted 1 year ago #


    According to my Apache error log, the apache tries to redirect the dashboard url to the default apache site, where wp-admin doesn't exist, of course.

    Kind Regards,


  3. tgruendl
    Posted 1 year ago #

    The problem was the ServerAlias directive, a p too much, I didn't see because of the punycode. :)

    Problem solved, works like a charm now.

    Kind Regards,


Topic Closed

This topic has been closed to new replies.

About this Topic