Support » Localhost Installs » multisite problem: can only access main site

  • I’m running Windows 7 and Firefox. I’ve installed WP on a localhost (Xampp). I’ve created a network to develop my site in three languages: main site at the root, two more sites in subdirectories: mainsite/es and mainsite/en. Everything worked fine until last Friday: I created pages, posts, I installed plugins… Then on Saturday when I try to start working on it some more, big problem.

    -I can access the Network admin dashboard and the main site dashboard, and I can view the home page of the main site.

    -When I try to see any other pages on the mainsite (even posts or comments), or one of the other sites, I get redirected automatically to http://localhost/xampp/.

    -When I try to access the dashboard of one of the subsites, I get this error: Object not found!

    The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

    If you think this is a server error, please contact the webmaster.
    Error 404
    Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7

    The only changes I may have made between Friday and Saturday are: updating some plugin and perhaps updating WP version to 3.5.1. I’ve tried deactivating all plugins, reinstalling WP (without uninstalling first of course) and a series of other tests to rule out other possibilities (reinstalling xampp, deactivating my Windows firewalls, trying other browsers…). Same problem.

    In addition, on Friday I installed WP and set up a network on my live server (Strato) and everything went smoothly (I didn’t install WP manually though, Strato provides an application called AppWizard that does it for you).

    On Saturday I created the same sites as in my localhost (main site on the domain and two sites in subdirectories, /es and /en). When I try to access the dashboard of the subsites, it takes a long time trying to load and then I get an error of the kind “Not redirecting properly”, “Too many redirections” (it depends on the browser). When I try to see the subsites, I only get a blank screen. That may be because I suppressed all themes in the network admin and installed a new one. It is network activated but not active in the subsites cause I couldn’t access the subsites dashboard. So no active theme in the subsites now. The only improvement on the Xampp situation is that in Strato I can see the pages, posts and comments on the main site.

    So, I don’t know if the two problems are related. They did happen at the same time. I’ve deactivated all plugins on Strato to no avail. I’ve also accessed my Strato WP from another computer and that didn’t solve the problem. Can it be caused by updating to 3.5.1. WP version?

    Any other people having that kind of issues? I don’t know how to give you access to my localhost and I’m currently in the process of reinstalling WP in Strato, trying to locate more precisely where the problem starts. But I can provide you with screenshots or any other information you might require.

    Any help would be greatly appreciated, I’ve been stuck with this problem since Saturday and for professional reasons I need to get the site working as soon as possible.

    Thanks so much for reading !

Viewing 2 replies - 1 through 2 (of 2 total)
  • OK, update on the situation. I’ve reinstalled WP on Strato, so it’s brand new, no active plugins, no content and just the original themes. I’ve set up a network with subdirectories and created a subsite. I can see the subsite, even if the display is not quite right (no more blank screen). I still can’t access the subsite’s dashboard. Same message: not redirecting properly. Here’s the link:

    In the process, I’ve noticed that last Saturday I appear to have modified the .htaccess file from the Xampp installation. I may have done it thinking that it was the .htaccess from the Strato installation. In that case it has the text that WP tells you to put in it to set a network with subdirectories; and if the text for the previous version on WP was different – can that be one reason why things aren’t working?

    OK, the Strato problem is solved. It appears their AppWizard application does not install the original WP version but a “simpler” one for non-expert users. So first I installed WP manually through FTP instead of the application. I set up a network with subdirectories and created a subsite. Still didn’t work.

    Looking about the Internet for solutions I had a look at this page:, which described a problem similar to mine with its solution. After several tries to adapt Patrick’s version of his .htaccess to my case, the correct combination was found. Now my WP network runs perfectly.

    So, these are the exact contents that I put on my .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # END WordPress

    I’d like to emphasize that this text is slightly different from the one provided by WP during the installation process. Thanks a lot to my computer-expert friend who found the right page and the right combination.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘multisite problem: can only access main site’ is closed to new replies.