Support » Networking WordPress » Multisite Problem

  • Dear All,

    I have downloaded and installed WordPress 4.3, got through the quick install instructions and got WordPress installed and posted one simple Hi blog.

    So after that I turned on Multisite support and create a second site, but when I try to view or go to the dashboard, I am getting

    The requested URL /wpdemo/site2/wp-admin/ was not found on this server.
    The requested URL /wpdemo/site2/ was not found on this server.

    Am I missing something here? How can check if I have done this correctly? Are there folders created for first and second sites?

    Charles

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi Charles.

    The only folders for new sites will be in the /wp-content/uploads/sites/. But thet is only for uploaded images etc.

    Did our install wordpress in site root or in its own directory?

    What does your .htaccess file look like?

    Hi Frans,

    First, I installed WP 4.3 on AWS, and it’s in the root directory of /var/www/html/sites/wpdemo

    Here is the .htaccess

    RewriteEngine On
    RewriteBase /wpdemo/
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Ok, I did not answer the question correctly. The WP 4.3 is untared to /var/www/html/site/wpdemo directory.

    The apache httpd.conf has a entry – DocumentRoot “/var/www/html/sites”

    Here is part of the httpd.conf

    DocumentRoot “/var/www/html/sites”
    #
    # Relax access to content within /var/www.
    #
    <Directory “/var/www”>
    AllowOverride None
    # Allow open access:
    Require all granted
    </Directory>

    # Further relax access to the default document root:
    <Directory “/var/www/html/sites”>
    #
    # Possible values for the Options directive are “None”, “All”,
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that “MultiViews” must be named *explicitly* — “Options All”
    # doesn’t give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs/2.4/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be “All”, “None”, or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride None

    #
    # Controls who can get stuff from this server.
    #
    Require all granted
    </Directory>

    Ok, I found the problem. So stupid of me, it was the line under

    <Directory “/var/www/html/sites”>

    AllowOverride None

    must change to

    AllowOverride All

    After I changed the line, restart apache2 server then everything works now.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Multisite Problem’ is closed to new replies.