Support » Plugin: W3 Total Cache » multisite on nginx, single config for all, empty minified files for subdomains

  • Resolved nabtron

    (@nabtron)


    Hi.

    I have a multisite setup on nginx.

    The w3tc is setup to use single config for all sites.

    The main domain works perfectly fine.

    However the multisite subdomains minified files are empty.

    Kindly suggest the solution.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @nabtron,

    I am sorry you are having issues with multisite setup.
    Can you please share your URL and also share more details about the issue you are having?

    @vmarko

    Thanks for responding.

    The domain with error is: http://bit.ly/2LPmdBp

    However if you see the source, the w3tc is linking to minified files with main domain name (not this subdomain) and thus it’s empty

    If we open the same linked file and change the domain name to subdomain manually, then it does work fine.

    Please let me know if there is any way to fix it.

    Thanks

    • This reply was modified 3 months, 2 weeks ago by  nabtron.
    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    Have you tried to untick “Use single network configuration file for all sites.”? And configure W3 Total Cache for each one?

    @vmarko

    yes, i did uncheck it too but nothing changed.

    I have moved the above link to a diff server for now, without w3 total cache on it.

    To test, here is another test subdomain showing same error: http://bit.ly/2K6FTyv

    Please advice.

    How can i debug? any direction to begin please?

    Using nginx, ubuntu 16.04, virtualmin

    Thanks

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @nabtron,
    Unfortunately, in order to inspect this further, I can only offer you our Professional support in Performance>Support so we can do the Performance Audit.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Hi there @nabtron I see you reported this thread to the moderators. Please note that we are just the folks who enforce the rules around all of WordPress.org.

    If you really do need a moderator, please add a reply letting us know why before you hit the report button.

    @macmanx

    Hi. I thought you would see it yourself so didn’t mention myself.

    I had an impression that pushing users towards “paid” support on this support forum is discouraged.

    So as per the last reply of the plugin author, instead of pointing out how i can debug it myself (not asking him to do it on my behalf), he refused that and asked me to pay them for further help.

    I hope it helps.

    Thanks.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Plugin developers are welcome to conduct their business how they see fit. If one of those things is to only provide support for a fee, that’s fine by us, as long as it’s done elsewhere.

    What I think you’re confusing this with is that we don’t allow plugin developers to support their commercial/paid products here.

    @vmarko

    solved it, plz add this fix in your next update.

    version: 0.9.7.5
    this is used when the minify “rewrite url structure” is turned off.
    file: Minify_Core.php
    line: 118
    checks for: network_site_url(), should check for home_url()

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @nabtron,

    Thank you for the provided information. We’ve inspected this and this is now fixed.
    https://github.com/W3EDGE/w3-total-cache/commit/83987e57f2da403fbe15fc2da15df691ee195a44

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.