WordPress.org

Support

Support » Localhost Installs » Multisite on localhost admin reject

Multisite on localhost admin reject

  • I have set up multisite on localhost, but cannot get into dishboard of child sites, while I can see the front end of them. If I try to enter as admin, I get no error and no message at all, just empty login & pass fields every attempt to enter.

    It looks like as if I enter successfully and redirected successfully, but then redirected one more time on login page.

    I have already one multisite installation on a hosting and did not experience such a problem with it. But localy I fail to set up it.

Viewing 14 replies - 1 through 14 (of 14 total)
  • It sounds like something is going wrong when setting the cookies for your subsites. Do you have any way to inspect the cookies that are being set to see if they match the location of the sites?

    It sounds like something is going wrong when setting the cookies for your subsites.

    Yes.

    Do you have any way to inspect the cookies that are being set to see if they match the location of the sites?

    No.
    I used Opera to inspect cookies. But in new Opera it does not work.
    How would you advise me to inspect cookies?

    I don’t inspect cookies very often, so I’m not sure how much information you can glean, but I have Cookie Manager and Edit This Cookie installed in Chrome; they might help.

    Curtiss, thank you for advice!
    But I cannot login at all from Chrome, while see front end of all sites.
    And it write to me:
    “This cite has no cookies”

    I checked Chrome, but it is OK, on other sites it manage cookies correctly and show them to me.

    I have set up a new MSWP on hosting – no problems.
    But under Windows 7 there is a problem with sending cookies.
    Don`t know how to research it further.

    That makes sense, Eugene1. More than likely, somewhere in that Windows 7 installation, there are probably system-level security settings that are keeping browsers from setting specific cookies on localhost. It’s possible the settings are within your anti-virus/firewall program.

    In my case, I’ve found that it’s nearly impossible to get Internet Explorer to recognize wildcard cookies (cookies that should work for all subdomains on a specific domain), as it won’t let you add that type of thing to the “Trusted Sites” list properly. There are similar rules that can be set on a system-level within Windows.

    As far as I understand, it does not makes sense. In no way.
    1) My firewall rules I know, and turning firewall off change nothing.
    2) I don’t use IE.
    3) “system-level within Windows rules” hardly can penetrate between server and browser. They communicate almost directly.

    Also, sending cookies error might be catchable…
    Or, at least seen in error logs.
    But I have only this in logs:

    127.0.0.1 - - [12/Apr/2013:14:09:05 +0000] "POST /wp-login.php HTTP/1.1" 302 -
     127.0.0.1 - - [12/Apr/2013:14:09:14 +0000] "GET /wp-admin/ HTTP/1.1" 302 -
     127.0.0.1 - - [12/Apr/2013:14:09:17 +0000] "GET /wp-login.php?redirect_to=http%3A%2F%2Fen.signals%2Fwp-admin%2F&reauth=1 HTTP/1.1" 200 2405

    That kind of sounds like the login loop of doom…

    Have you deleted all the cookies for that site?

    That kind of sounds like the login loop of doom…

    Yes.

    Have you deleted all the cookies for that site?

    I could not. Chrome never receive cookies at all. Opera, probably, have valid cookies only for main domain.
    Possibly, cookies that WP attempting to send, have illegal char because of wrong localization.
    Apache under Linux correct the char, under Window does not.

    In any case, it would be reasonable to inform user about send cookie failure.

    I could not. Chrome never receive cookies at all. Opera, probably, have valid cookies only for main domain.

    Delete ALL cookies in chrome. All. Every last one.

    Chrome’s an idiot.

    OK. I have deleted ALL cookies in Chrome. No difference. I cannot login by Chrome, only by Opera and only to parent site.

    It has to be something you did wrong on setup.

    How did you set up Apache and PHP on your computer?

    How did you set up Apache and PHP on your computer?

    Apache, PHP and MySQL was set by pack: “HomServ”.
    I have used it for years without any problems.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Multisite on localhost admin reject’ is closed to new replies.
Skip to toolbar