Support » Networking WordPress » Multisite not using subdomains as hostname in From-address when sending emails

  • camiloapr

    (@camiloapr)


    I have a Multisite installation where I’m facing somekind of bug relating the hostname used when WordPress sends emails (I’ve test it with WordPress admin emails and Contact Form 7).

    For example, if I try to send an email from wordpress@site.example.com the email gets sent but the from address is somehow changed to wordpress@example-cname-id.elb.amazonaws.com. Where example-cname-id.elb.amazonaws.com is the alias I have in my DNS for the domain site.example.com, which is one of the sites in the Multisite . Weirdly enough, if I instead try to send the email from wordpress@example.com the From Address doesn’t change. The latter wouldn’t be a workaround since I really need to send the emails from a subdomain hostname, which in this example would be wordpress@site.example.com

    Some extra details:

    • If I delete the CNAME record and replace it for an A record the From Address is not changed. Yet, this option would not work as a solution since it would require to change all the DNS and servers setup.
    • I don’t face this bug in single-site installations with a similar DNS set up (also using subdomains aswell).
    • I’m using WordPress 4.9.8.
    • The Multisite is on Subdomain mode.

    has anyone ever faced a similar issue?

Viewing 2 replies - 1 through 2 (of 2 total)
  • JNashHawkins

    (@jnashhawkins)

    You’ll need to talk to AWS about the emails and addresses themselves as the multisite sends its emails from the SuperAdmin’s address. There’s probably some way to change that default address via the Hosting Control panel if there is one… else from the UNIX command line.

    You might be better off to get email from some other source such as your domain registrar. I’m not sure how AWS does email.

    —-

    If I remember right there’s a place to change the individual site’s admin user by navigating to…

    Dashboard –> Network Admin –> My Sites —> Sites and then choose settings and look down to admin email. Remember WordPress doesn’t create your email address… it must already exist! That’s the job of your host or Control Panel.

    Changing the user for the ‘main’ account will probably set the networks default address to that some address but I’ve never had to change that once set.

    I’m looking into doing some hosting via a multisite and planned on not offering any email services with that as most domain registrars offer email addresses with their domains and very nice email services as a premium service.

    Also, the plugins I’ve worked with all seemed to have a way to set the ‘From’ address of any emails they send site visitors from what I’ve seen. Contact the plugin developer for more info as needed.

    Hope this helps!

    camiloapr

    (@camiloapr)

    Hi

    Regarding what you mentioned:

    • Yep, Contact Form 7 provides that feature to set the “From Address” so I am setting the emails to be sent from wordpress@site.example.com , but I’m facing this bug where the hostname is getting swapped by the CNAME where the Multisite is hosted. furthermore, If I try to send the emails from wordpress@example.com(a root domain) the hostname is not swapped. So this bug is only happening when the email is using a subdomain in the hostname
    • AWS is just where I’m hosting the Multisite. Apart from the multisite I’m using it to host single-sites WP installations and I don’t find this issue there.
    • Changing the admins email address doesn’t fix the issue. Also, yeah, the email addresss already exists.
    • This reply was modified 1 year ago by camiloapr.
    • This reply was modified 1 year ago by camiloapr.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Multisite not using subdomains as hostname in From-address when sending emails’ is closed to new replies.