Support » Localhost Installs » multisite not showing up under tools

  • Resolved dagmarprime

    (@dagmarprime)


    I am trying to get multisite working.

    I have a single-site instance working.

    I have edited /var/www/html/wordpress/wp-config.php

    to add

    define( ‘WP_ALLOW_MULTISITE’, true );`

    above

    /* That’s all, stop editing! Happy publishing. */

    I have logged out of wp, restarted apache2,gone back into the wordpress admin interface, and

    Tools -> Network

    does not appear.

    Is there some other setting that I need to set?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Joy

    (@joyously)

    You didn’t need to restart Apache.
    Are you working from https://wordpress.org/support/article/create-a-network/ ?

    You have some extra characters in your define statement here in your post. Can you make sure that you do not have anything extra, and that the quote marks are really single quote marks? (PHP is picky about that.)
    You can enable DEBUG mode if you can’t find the problem.

    dagmarprime

    (@dagmarprime)

    Joy,

    Here is code copied straight (I am purposively not using a code block) from /var/www/html/wp-config.php
    …lines above

    define( ‘WP_DEBUG’, false );

    define( ‘WP_ALLOW_MULTISITE’, true );

    /* That’s all, stop editing! Happy publishing. */

    lines below…

    Hmmmm… I’l try turning debug on. I’ll look for where the debug logs go.

    JNashHawkins

    (@jnashhawkins)

    Are Pretty Permalinks working? You need those!

    All Plugins disabled? You need those off!

    Refresh the dashboard and then it’s Tools and then Network setup.

    JNashHawkins

    (@jnashhawkins)

    Also, is WWW/html your webroot? Or is it a subdirectory of webroot?

    dagmarprime

    (@dagmarprime)

    I turned on debug mode, and debug logging.
    No visible errors when loading wp-admin.php, and no ../wordpress/wp-content/debug.log exists.

    dagmarprime

    (@dagmarprime)

    @jnashhawkins

    Thanks!

    The Apache2 index.html that is provided with my Ubuntu18.04 install does not show what modules are installed or active.

    How can I check whether mod_rewrite is working? I expect mod_rewrite is a mod to Apache2, and that WP might have a setting to use Pretty Permas.

    How would I detect whether PrettyP is available and working?

    As a note, the page

    Create A Network


    has a link

    Introduction to Blogging


    that is bad, since it has the %20 in it.

    That link is at the text

    Using mod_rewrite or lighttpd you can produce much nicer permalinks (see Pretty Permalinks).

    The link should probably be directly to

    Introduction to Blogging

    But the text there does not explain how to check whether mod_rewrite is installed and active, or how to additionally turn on PrettyP in the WP interface, if that is needed.

    And, where is webroot specified?

    Browsing localhost/phpinfo.php makes use of the file /var/www/html/phpinfo.php, whereas wp-admin is at /var/www/html/wordpress/wp-admin.php.

    JNashHawkins

    (@jnashhawkins)

    Any permalink other than the ‘old default’ with the numbered posts (plain) is fine.

    Dashboard –> Settings –> Permalinks I always choose ‘Day and name’. Just look at a post listed in your ‘blog’ page before and then after to get a idea if Permalinks are now custom (Pretty).

    Browsing localhost/phpinfo.php makes use of the file /var/www/html/phpinfo.php, whereas wp-admin is at /var/www/html/wordpress/wp-admin.php.

    So your webroot is www/html but your install is in www/html/wordpress!

    Now is this a localhost? (I mostly hate localhosts).

    What does the outside URL to the website look like?

    You might want to deal with this first to get WordPress itself to run from what I think is your webroot.

    https://wordpress.org/support/article/giving-wordpress-its-own-directory/

    That should clear the way for WordPress to run the network and let you actually get to the network setup page then.

    dagmarprime

    (@dagmarprime)

    Sorry for the above. I entered URL’s as text, and they were auto-converted to snapshots or whatever they are called.

    Regarding your advice to handle webroot and server root;

    The page at the link talks about moving wordpress as a file structure out of the root of the server, to avoid clutter.

    Right now, my html file structure is like this:
    #subdirs
    /var/www/html/wordpress/ # see below
    /var/www/html/phpmyadmin/
    #files
    index.html
    phpinfo.php
    (no .htaccess)

    My wordpress file structure is like this:
    \var\www\html\wordpress\wp-admin\
    \var\www\html\wordpress\wp-content\
    \var\www\html\wordpress\wp-includes\
    #files
    wp-config.php
    wp-login.php
    (etc)
    (no .htaccess)

    So, my wordpress core is in its own happy subdir.
    At present, to get to the front page of the website from a browser logged in to WP, I go to localhost/wordpress/

    To be able to view this website at localhost/
    I suppose I’d use an .htaccess file, right?

    Then I’ll probably be able to set up mutli-site?

    Thanks,

    Jud

    JNashHawkins

    (@jnashhawkins)

    You do seem to already have WordPress installed into a subdirectory so…

    Those instructions I referenced tell you how to copy your present htaccess and index.php files into the root directory if you will follow those instructions. You’ll need to modify the two files a bit but the instructions are there. I always use method two myself.

    https://wordpress.org/support/article/giving-wordpress-its-own-directory/#method-ii-with-url-change

    Sometimes it might be advisable to find a sysadmin or developer to step in and help. With your localhost setup you might need someone to give you some hands-on help with this first setup. I’m very stubborn so I usually shy away from asking for help… often I regret that choice.

    Just to cover the bases for other readers…

    You may not have a htaccess if you are running Nginx or a Windows-based server.

    Windows-based webservers give me the hives! That’s just very ‘foreign’ to me.

    Hope this helps and sometimes you’ll find a local ‘expert’ by checking out some meetups or asking for a bit of help from your local community college or Linux users group.

    dagmarprime

    (@dagmarprime)

    JNashHawkins, thanks for sticking with this.

    The WP install I am working on is a brand new one. No real posts or pages after instaallation.

    Perhaps it will be easier to nuke the current, empty instance, then re-install.

    If I reinstall, I’d like to install WP in a location that will be optimal for multisite.

    Since I plan to use a plugin to create static copies of the sites managed on the multisite WP, and the plugin will rewrite URL’s, the URL structure used by the WP multisite is not critical. Noentheless, if there are reasons that one structure or another will be easier to install or use, I’d pay attention to that.

    If you were me, what source would you use to install a brand new instance of WP, configured before production use as multisite?

    Thanks.

    dagmarprime

    (@dagmarprime)

    @joyously @jnashhawkins,

    Thanks for your help.

    I deleted my install (it was brand new, and empty) and reinstalled, and this time the .htaccess files had been created.

    I proceeded with the wordpress.org standard instructions.

    Seems to have worked.

    Thanks again.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘multisite not showing up under tools’ is closed to new replies.