Support » Multisite » [Resolved] Multisite Network Setup Issue – file paths maybe?

[Resolved] Multisite Network Setup Issue – file paths maybe?

  • I have a Multisite install on a subdomain at law.traverselegal.com, which is setup to use subfolders, i.e. law.traverselegal.com/defamation-libel-slander.

    law.traverselegal.com is working fine as the network admin. But when I created a site beneath – law.traverselegal.com/defamation-libel-slander, it seems as if there are some file path issues. The same goes for the admin – http://law.traverselegal.com/defamation-libel-slander/wp-admin.

    The Multisite install is in a subfolder of the root domain of traverselegal.com, which also runs off WordPress. So, the subfolder with the Multisite install is at the same level as the wp-(admin, content, includes) folders of the root domain. I hope that makes sense. 🙂

    I’ve done my research on this forum and it clearly states that what I’m trying to achieve IS possible…I’m just not sure where I’ve gone wrong. Thank you in advance…

Viewing 12 replies - 1 through 12 (of 12 total)
  • Based on my research in the threads, I’ve been thinking my issue is server side. And I just came across this article that describes my exact issue, confirming the need for further server configuration:


    Though I haven’t implemented the fix yet, I’m 99% sure this method will – I just wanted to point others to this article in case they’re experiencing a similar issue and are seeking answers.

    So multisite is installed in public_html/law then? What’s in your .htaccess in THAT folder?

    Yes…well, /sub-law actually. 🙂 And that’s where the .htaccess is located, as well.

    As far as the code goes in the .htaccess file, I’ve switched it around a few times as I’ve copied the code from various blog posts and forum threads on this topic, but originally I used the code that was provided in the Network setup during the multisite installation. That page is no longer visible in the admin, unless I’m missing something…

    Should the .htaccess for the multisite install be added to the root at /public_html? And if I’m already using .htaccess there, just add in the new rules…?

    No, the .htaccess in /public_html is for the install based in public_html (i.e. domain.com) The one in public_html/sub_law is for sub_law.domain.com, if that makes sense.

    I’ve heard tell people say that the two .htaccess’s conflict, but I’ve done it myself without issues many times.

    What’s in the .htaccess for sub-law, though? And yes, it matters 🙂

    I’m on my home computer, so unfortunately I don’t have access to the site right now. (Dang it – now that I’ve got support right on hand! :)) I will post the code first thing tomorrow morning, though. And thank you for your help!

    Here’s the code in the .htaccess for /sub-law:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?blogN/files/(.+) wp-content/blogs.dir/N/files/$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    The only thing that MIGHT be wrong is RewriteBase / – Is that what it told you to put in on the wp-admin/network/setup.php page?

    Yes. I also tried it with /sub-law/, but that didn’t work either.

    Tried RewriteBase / with /sub-law/, that is. 🙂

    Do you have any caching plugins installed on the traverselegal.com site?


    Hey Ipstenu – the .htaccess file had a hidden .txt extension on the end. 🙂 Completely my oversight. Needless to say, everything is working great now based on all default installation instructions. Thank you again for your help!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Multisite Network Setup Issue – file paths maybe?’ is closed to new replies.
Skip to toolbar