Support » Plugin: W3 Total Cache » Multisite Manual Minify not working properly

  • Hi,
    we are experiencing problems with the manual minify process on multisites.
    The minification works fine on the main site but on the other “installations” (subfolder) the minified file gets included AND the normal styles and scripts. So the load is much higher than without minification.

    I played around with the setting that every multisite is sharing the config or has an individual but it didn’t help.

    Here is the css minify extract from the master.php

     "minify.css.groups": {
            "9682b": {
                "default": {
                    "include": {
                        "files": [
                            "wp-content\/plugins\/js_composer\/assets\/lib\/bower\/font-awesome\/css\/font-awesome.min.css",
                            "wp-content\/plugins\/smooth-scroll-up\/css\/scrollup.css",
                            "wp-content\/plugins\/svg-support\/css\/svgs-attachment.css",
                            "wp-content\/plugins\/wordpress-social-login\/assets\/css\/style.css",

    Does someone have an solution for this problem?

Viewing 4 replies - 1 through 4 (of 4 total)
  • bgdstr

    (@bogdanstratulat)

    You may want to check the tutorial located at:

    https://premium.wpmudev.org/forums/topic/w3-total-cache-plugin-for-multisite

    Alternatively, please keep in mind that we can configure the plugin for you. You can request that from your Performance menu > Support > Plugin COnfiguration.

    Thread Starter yesdevs

    (@yesdevs)

    @bogdanstratulat Thanks for the reply!

    Unfortunately did the link you posted not contain any tutorial.

    I just want to make sure we’re on the same page. I am not talking about the wpmudev multisite service, but rather the WordPress multisite functionality.

    Here is an image of devtools network tab. The following image describes, what happens when navigating to a network site e.g “example.org/se” or example.org/”. As you can see are both the minified files AND the normal styles and scripts included.
    devtools network tab

    Any help is highly appreciated.

    • This reply was modified 2 years, 6 months ago by yesdevs.
    • This reply was modified 2 years, 6 months ago by yesdevs.
    Thread Starter yesdevs

    (@yesdevs)

    Pinging 🙂

    bgdstr

    (@bogdanstratulat)

    you may want to enable debug for minify and check what is put in comments at the end of the page in page source. That should help. Also, as a side note, our developers are working on improving minification in our next release.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Multisite Manual Minify not working properly’ is closed to new replies.