Support » Networking WordPress » Multisite Log In Problem with Cookies Error

Viewing 6 replies - 1 through 6 (of 6 total)
  • Experiencing the same problem since upgrade to 3.9. I can log into root site and first 2 subdomains but after that get the Cookie blocked error and 3 header errors (…/pluggable.php on line 861)

    No solution found so far.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    https://core.trac.wordpress.org/ticket/27373

    So there was actually a fix but it seems not to work.

    Both of you should try manually reinstalling the WP core files

    Also try turning on WP_DEBUG (it’s in your wp-config.php file) and see if that gets a better error.

    Thanks Mika. Tried all of the suggestions in the link you sent and finally found 1 that worked. Adding the following to wp-config.php allowed me to login into the remaining multisite subdomains:

    define(‘COOKIE_DOMAIN’, false);

    Not sure of the ramifications of leaving this in place so plan to comment it out when done configuring the sites. I’ve verified that once removed wp-admin will again be broken so this bug actually serves as a security measure should the pwd get compromised.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    It’s fine if you leave that in. It means your server isn’t really setting cookies right for some reason, which is PROBABLY a plugin issue.

    Howdy,

    Just ran into this issue as well and it turns out that the problem is that it’s not recognizing the mapping of the alternative domains (in your case: cappermarket.com and capperads.com) to the primary capperwebsites.com.

    So it’s trying to send a cookie with the primary domain capperwebsites.com even though you are browsing cappermarket.com. Cross domain cookies don’t work. In other words, I can’t set a cookie for microsoft.com from my local website.

    So you need to go into the main network admin -> Settings (left nav) -> Domains .. and then add the domain name. If you are unsure of your “siteid”, you can find that by going into the Network Admin -> Sites and hover over the site in the list without clicking on it — you’ll see in the URL the ID # of the site. E.g. /wp-admin/network/site-info.php?id=7 — the Site ID is 7.

    Hope this makes sense and helps, I tried the COOKIE_DOMAIN in the wp-config.php and that didn’t help … this solved the problem.

    Here’s a link to an article explaining the same thing, FYI:

    Multisite: How to add new sites and map a custom domain

    kamiel79

    (@kamiel79)

    Yes, I have the exact same problem using WP 4.1 Dinah: cross-domain cookies.
    Solution was the plugin and instructions on http://wpengine.com/support/multisite-how-to-add-new-sites/
    worked. Thanks!
    (Plugin sounds like a good candidate for core)

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Multisite Log In Problem with Cookies Error’ is closed to new replies.