WordPress.org

Support

Support » Localhost Installs » Multisite local install with XAMPP – Subdomains

Multisite local install with XAMPP – Subdomains

  • I successfully configured my local installation of WordPress 3.5 using XAMPP. I set up virtual hosts in Apache so I could reach my development site under wordpress.dev.

    Now after enabling WordPress Multisite I’m getting the following error:

    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.
    
    If you think this is a server error, please contact the webmaster.
    
    Error 500

    As per the Network setup instructions added the following code to my wp-config file:

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'wordpress.dev');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    And I added this code to my .htaccess file:

    RewriteEngine On
    RewriteBase /
    options +FollowSymLinks
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) C:\Program Files (x86)\xampp\htdocs\wordpress3.5/$1 [L]
    RewriteRule ^(.*\.php)$ C:\Program Files (x86)\xampp\htdocs\wordpress3.5/$1 [L]
    RewriteRule . index.php [L]

    After browsing the interwebs I tried to enable mod_rewrite in Apache as per the instructions here: http://www.leonardaustin.com/technical/enable-mod_rewrite-in-xampp

    This didn’t work…

    I appreciate any help you could offer on this.

Viewing 6 replies - 1 through 6 (of 6 total)
  • That .htaccess is all messed up… Is that the one WP gave you when you activated Multisite?

    Yes

    With the C:\? Oh, it’s XAMMP… Damn. I’m gonna move this to the localhost subforum, since they know more about that.

    Hi there,

    I had the similar problem. I’ve installed the WP3.5, enabled network and when I added a site, it gave me “Error 403” when accessing the site dashboard although the main site worked fine.

    I’ve had a look at the .htaccess as that was what I expected to be the cause of the problem. I’m not an expert in .htaccess commands, but what I basically did, was just combine the commands I have from WP3.4 network with the new one on WP3.5 network.

    Please try to make a backup copy of your .htaccess file and place this to the original one:

    RewriteEngine On
    RewriteBase /wordpress3.5/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    This is actually the same as I have as I can see you’ve installed the WP3.5 into the “wordpress3.5” folder like I did. So it should work for you on URL “http://localhost/wordpress3.5/” (I don’t know if it works on the “wordpress.dev” you’ve set up in virtual hosts though).

    Also, you don’t have to enable mod_rewrite in XAMPP as it should be enabled by default.

    If this doesn’t work for you, please consider to move/reinstall your XAMPP installation directly to root “C:/”. Now you have it in “C:\Program Files (x86)” which I think is not really desirable for XAMPP, but I’m not sure about this advice 😉

    Regards,

    Oliver

    lemmonaid your solution worked for me for a local installation! Thanks!

    marek91, I am also having the same issue as with you on Xampp on localhost…did you find any solution to it?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Multisite local install with XAMPP – Subdomains’ is closed to new replies.