Support » Plugin: Multisite Language Switcher » Multisite Language Switcher Options is empty

  • Resolved pirmg

    (@pirmg)


    Hi Dennis,

    I can’t see anything in Settings/Multisite Language Switcher. Only the message: “Multisite Language Switcher is almost ready. You must complete the configuration process.”

    I have a network install with 3 sites, all under the same super-admin, and the plugin is activated at the network level. Same screen coming up empty on all three sites.

    Even though the plugin is activated, when I go into edit, the only function that’s activated is MultisiteLanguageSwitcher.php. All other functions (including MslsAdmin.php) show up as de-activated. ???

    I’m sure I’m missing something simple, but I’ve scanned all support threads to no avail. Thanks in advance!

    https://wordpress.org/plugins/multisite-language-switcher/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Dennis Ploetner

    (@realloc)

    You don’t need to edit files of the plugin. Just save the settings of plugin in each of your site …

    Read on here: https://wordpress.org/plugins/multisite-language-switcher/installation/

    I only mentioned the active/inactive flag on the plugin functions in case that gave you a hint on what’s going on. I’m not editing them (and realize now that that flag seems to be unreliable anyway).

    You’re saying: “Just save the settings of plugin in each of your site” but that’s precisely what I cannot do: the Settings/Multisite Language Switcher screen is blank (except for the message that I need to complete the configuration process)…

    Plugin Author Dennis Ploetner

    (@realloc)

    I don’t know what you mean with active/inactive. The plugins uses an autoloader class.

    When you see a blank screen there must be a reason for that. Can you look in the logfiles what’s going on? Do you have already tried to enable the DEBUG output in your wp-config.php?

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', true);
    @ini_set('display_errors',0);
    define('SCRIPT_DEBUG', true);

    You will find the messages in /wp-content/debug.log

    Cheers,
    Dennis.

    Couldn’t get debug to trace anything. Tried to deactivate / reactivate plugin, uninstall / reinstall…

    It worked well when I had 2 sites, and my current problems started when I created a third site. Perhaps that gives you a clue? I haven’t tried to uninstall multisite network because I didn’t want to go chase after and delete the corresponding database tables, but I can try and do it if you feel that’s the only way to go. I’d rather not uninstall the theme (too much custom CSS in there without a child theme).

    Thanks in advance for any idea you might have! 🙂

    Plugin Author Dennis Ploetner

    (@realloc)

    You should at least try to activate a standard-theme for exclude your theme as the reason.

    I did (twenty-fourteen), but it didn’t change anything…

    Plugin Author Dennis Ploetner

    (@realloc)

    OK, send me credentials to look into your WordPress site: re@lloc.de

    On its way. Thanks!

    Dennis,

    I edited your MslsAdmin.php a bit to get rid of that class=”clear” that was hiding the MSLS settings form:

    <form class="clear" action="options.php" method="post">

    is now:

    <form action="options.php" method="post">

    I can now see and use the options form 🙂 Thanks for the excellent support, follow up and for pointing me in the right direction!

    Case solved!

    Plugin Author Dennis Ploetner

    (@realloc)

    OK, very good, I will check what I have to do here. 😉

    Cheers,
    Dennis.

    Hello!

    I have an issue with my blog. All my posts are now “inactive” (in other words, hidden from my blog). I wanted to add another language to my blog but after adding Russian my content suddenly became “inactive”.

    Under the tab “WPML” It says that “In order to edit or delete these you need to activate the corresponding language first” though when I add the languages (English: I can’t even select this one as it might be a default setting? ; Korean ; German ; Russian: the one I wanted to add), and press “save” it loads and then just remains the same.

    Could you please help me fix this issue. It is SUPER urgent!
    Thanks a lot for your help!

    Plugin Author Dennis Ploetner

    (@realloc)

    I think you are at the wrong place: This is the support for the “Multisite Language Switcher” and not for WPML. And BTW please don’t comment on resolved issues. Open you own so other users with the same problem could find the information much easier…

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Multisite Language Switcher Options is empty’ is closed to new replies.