Support » Plugin: Redis Object Cache » Multiple sites on one server issues

  • Resolved casperclickbizz

    (@casperclickbizz)


    Hey! I’m using redis object cache succesfully on one site, but can’t get it to work on the second. I added the database and salt settings to the wp-config. It registers in the diagnose.

    Site 1 diagnose: `Status: Verbonden
    Client: PhpRedis (v5.3.7)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 5.3.7
    Relay: Not loaded
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 7.4.29
    Plugin Version: 2.0.25
    Redis Version: 6.2.6
    Multisite: No
    Metrics: Enabled
    Metrics recorded: 71
    Filesystem: Working
    Global Prefix: “wp_”
    Blog Prefix: “wp_”
    WP_REDIS_HOST: “127.0.0.1”
    WP_REDIS_PORT: 6379
    WP_REDIS_DATABASE: 0
    WP_REDIS_TIMEOUT: 1
    WP_REDIS_READ_TIMEOUT: 1
    WP_CACHE_KEY_SALT: “site1.com”
    Global Groups: [
    “blog-details”,
    “blog-id-cache”,
    “blog-lookup”,
    “global-posts”,
    “networks”,
    “rss”,
    “sites”,
    “site-details”,
    “site-lookup”,
    “site-options”,
    “site-transient”,
    “users”,
    “useremail”,
    “userlogins”,
    “usermeta”,
    “user_meta”,
    “userslugs”,
    “redis-cache”,
    “blog_meta”
    ]
    Ignored Groups: [
    “counts”,
    “plugins”,
    “themes”
    ]
    Unflushable Groups: []
    Drop-ins: [
    “advanced-cache.php v by “,
    “Query Monitor Database Class (Drop-in) v3.9.0 by John Blackbourn”,
    “maintenance.php v by “,
    “Redis Object Cache Drop-In v2.0.25 by Till Krüss”
    ]`

    Site 2 diagnose: `Status: Drop-in niet geïnstalleerd
    Client:
    Drop-in: Not installed
    Disabled: No
    PhpRedis: 5.3.7
    Relay: Not loaded
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 8.0.18
    Plugin Version: 2.0.25
    Redis Version: Unknown
    Multisite: No
    Metrics: Disabled
    Metrics recorded: null
    Filesystem: Working
    WP_REDIS_HOST: “127.0.0.1”
    WP_REDIS_PORT: 6379
    WP_REDIS_DATABASE: 1
    WP_REDIS_TIMEOUT: 1
    WP_REDIS_READ_TIMEOUT: 1
    WP_CACHE_KEY_SALT: “site2.com”
    Drop-ins: [
    “advanced-cache.php v by “,
    “Query Monitor Database Class (Drop-in) v3.9.0 by John Blackbourn”,
    “maintenance.php v by ”
    ]`

    Please note that site 2 is currently off. Site 2 redirects to Site 1 instead of caching when I turn on the plugin. What am I doing wrong?

    Thanks in advance for helping!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter casperclickbizz

    (@casperclickbizz)

    Lol I named the topic multisite but this is about multiple sites on one server, NOT about multisite. My bad.

    Plugin Author Till Krüss

    (@tillkruess)

    Using WP_REDIS_DATABASE for each site will do the trick. Make sure to run Redis-cli flushall to wipe the entire cache once.

    Thread Starter casperclickbizz

    (@casperclickbizz)

    Hey Till, thanks for answering!

    I added `WP_REDIS_DATABASE’ to each site, as you can see the first one is 0 and the second one is 1. However, even after

    redis-cli flushall

    it unfortunately doesn’t work.

    Plugin Author Till Krüss

    (@tillkruess)

    Restart your server?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.