Multisite issue with subsite new domain (6 posts)

  1. howhuh
    Posted 2 years ago #

    I run WP 3.6 MU with a few subsites on subdirectory structure.
    All works fine, until I go to Sites > Edit site "x", change domain from networkdomain.com/site to subsite.com.

    The site is fully accessible using the new domain, including pages, posts and other site areas. Except for wp-admin. No matter if I try to access thru the Network admin or directly from the frondend, WP directs to "comsubdomain/wp-admin". If I try to access wp-admin directly by typing subdomain.com/wp-admin I am redirected to comsubdomain/wp-admin as well.

    Tried several things including network deactivating domain mapping. Also tried changing back the site url to networkdomain.com/site but that gives me a 404 on the frontend and a redirect of wp-admin to the mastersite admin panel.

    Please help!

    Ref: http://spark-renault.com | http://spark-renault.com/wp-admin

  2. howhuh
    Posted 2 years ago #

    PS: This is my wp-config content:

    /** Allow Multisite **/
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    /* define('DOMAIN_CURRENT_SITE', 'networkdomain.com'); */
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    define( 'BP_ENABLE_MULTIBLOG', true );

    Commented out the CURRENT_SITE to solve another issue (as directed through WP Support Forums).

  3. David Radovanovic
    Posted 2 years ago #

    Try double-checking the proper spelling of all your domains in Sites menu and also restore the commented-out DOMAIN_CURRENT_SITE.

  4. howhuh
    Posted 2 years ago #

    Hmm, checked all and restored the commented line but too bad, no change

    What could be the cause of this?

    UPDATE: I got it working using a detour. For people running into the same problem, this is what I did:

    De-link the custom domain name
    De-activate the subsite
    Create a new subsite using the custom domain name
    Replace the new subsite install database tables with the old one's

    Still wondering why this is happening. It's not only this subsite, whenever trying to change the location of any subsite, thing get messed up... Hope anyone has a better solution

  5. David Radovanovic
    Posted 2 years ago #

    Seems like a lot of work. Glad you got it fixed though.

  6. howhuh
    Posted 2 years ago #

    Yeah still waiting for the day WordPress doesn't have so many flaws

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.