Support » Networking WordPress » Multisite is on but sites are not linked when visited

  • So none of my multisite works well except for the main site:
    1) The linked blogs don’t have “My Sites” available on their dashboards, just the main blog
    2) New Themes includes are not available on linked blogs, just the main blog
    3) Any changes to titles/settings do not appear on linked blogs, just the main blog
    … and so on!

    So what did I do:

    I am trying to make a school website using blogs for the school I teach at. I already had some WP blogs installed based on ideas in seperate folder on my iPage account, for example:


    I installed a new WP blog on my iPage account directly into the same folder called /blog/ and followed the instructions to make a multi-site. Once active it didn’t give me the option of subdirectory, only subdomain, but I gave it a go but it gave the exact same problem as I have now.

    Anyway, I switched off from subdomain to subdirectory buy changing the config.php file to:

    define(‘SUBDOMAIN_INSTALL’, false);

    However whilst this did allow me to add my other sites in their folders without having to give each one a subdomain address and link them that way, the problems were still there.

    My .htaccess file looks like this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # END WordPress

    which is based on the instructions given and the advice I have already read elsewhere, but it did not help.

    To expand a little on a couple of the points at the top, when I go to the website for my Main Blog I can see “My Site” to go to the SuperAdmin Network Dashboard and all seems great. Added a theme to activate on each individual site.

    However, when I go to the Year 7 Blog (or any of the others for that matter) “My Site” disappears and there is no Theme or any changes since I first ever installed it. In fact it doesn’t even look like its linked at all.

    “My Site” shows it, but even if I click “Disable” to switch it off, it does nothing and I can still access the blog.

    So where abouts have I gone wrong, as I had the exact same issues when I tried subdomains and it did the same?

    Any help at all would be extremely grateful.

Viewing 1 replies (of 1 total)
  • Oh, oh. You say “this did allow me to add my other sites in their folders” but that they are not “linked”?

    How did you add your sub sites? There should be no additional files, no additional folders. When you add a sub site (ie signup.php) – no new directories or files are added – the new sites are virtual (you’ll see them in the main site’s database, but no additional files).

    It sounds like you have a collection of single versions of WP installed and are hoping multisite admin stitches them altogether.

    Install WP in http://domain.tld/blog/ (add nothing else in the folder to start)

    Get it up and running as a single WP first. Modify your wp-config to enable multisite then activate the network following the directions for subdirectory install under the Tools menu. (if you start with a brand new WP 3.5.1 there doesn’t need to be a rewrite for ms-files anymore) Copy/paste the changes to htaccess and wp-config from your own Network Setup screens whilst it installs.

    Add a subsite using only the signup.php – do not upload any new instances of WP to add a subsite.

    (If you have done what I suspect, deleting the unnecessary subsite folders you manually added may be all you need to do).

Viewing 1 replies (of 1 total)
  • The topic ‘Multisite is on but sites are not linked when visited’ is closed to new replies.