WordPress.org

Forums

Multisite installation gives blank page (9 posts)

  1. yeosteve
    Member
    Posted 3 years ago #

    Hi
    I've been looking for a week for an answer to this, but maybe someone can point me to the right place. I can't be the only person to have had this problem. I suspect it's a server problem, and there are two issues
    1) Before I can set up permalinks I have to edit wp-admin/includes/misc.php
    2) When setting up multisite, after editing wp-config.php, the network setup screen is blank. I found a fix which requires some core hacking (again) http://wordpress.org/support/topic/networkphp-is-blank-cant-create-a-network?replies=26

    From my phpinfo -

    Configure Command './configure' '--disable-fileinfo' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-mbstring' '--enable-pdo=shared' '--enable-sockets' '--prefix=/usr' '--with-curl=/opt/curlssl/' '--with-curlwrappers' '--with-freetype-dir=/usr' '--with-gd' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-pic' '--with-png-dir=/usr' '--with-sqlite=shared' '--with-xpm-dir=/usr' '--with-zlib' '--with-zlib-dir=/usr'

    I don't have to do either of these "fixes" on another server, but I want to use my own VPS and I can't work out what is different. Can anyone point me in the right direction?

  2. Wait, before you set up permalinks on single site or only on Multisite?

    Obviously corehacking is teh bad but which fixs did you do?

  3. yeosteve
    Member
    Posted 3 years ago #

    I've always had to do
    function got_mod_rewrite() {
    //$got_rewrite = apache_mod_loaded('mod_rewrite', true); //old line with false negative;
    $got_rewrite = true;//force the response to true as we know mod_rewite is installed;
    return apply_filters('got_rewrite', $got_rewrite);
    }\
    in misc.php to make permalinks work

    and the functions.php hack for multisite that I tried was changing
    function apache_mod_loaded($mod, $default = false) { ...
    to
    function apache_mod_loaded() {

    return true;
    }
    The original author wasn't proud of it either :)

    I'm hoping that these two problems might help someone pinpoint a server setup problem that I think must be causing it.

  4. The thing that stands out for me is you don't have mod_rewrite enabled if that's what's going on. What you're telling the code is "I have mod_rewrite, even though Apache isn't saying so."

    What's in your apache config?

    core mod_authn_file mod_authn_default mod_authz_host mod_authz_groupfile mod_authz_user mod_authz_default mod_auth_basic mod_include mod_filter mod_deflate mod_log_config mod_logio mod_env mod_expires mod_headers mod_unique_id mod_setenvif mod_proxy mod_proxy_connect mod_proxy_ftp mod_proxy_http mod_proxy_scgi mod_proxy_ajp mod_proxy_balancer mod_ssl prefork http_core mod_mime mod_dav mod_status mod_autoindex mod_asis mod_info mod_suexec mod_cgi mod_dav_fs mod_negotiation mod_dir mod_actions mod_userdir mod_alias mod_rewrite mod_so mod_bwlimited mod_disable_suexec mod_php5 mod_security2 mod_zeus

    I don't think it's PHP, but here's my config if it helps:
    './configure' '--disable-fileinfo' '--disable-mbregex' '--disable-pdo' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-mbstring' '--enable-sockets' '--enable-zip' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-bz2' '--with-curl=/opt/curlssl/' '--with-freetype-dir=/usr' '--with-gd' '--with-gettext' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pic' '--with-png-dir=/usr' '--with-xmlrpc' '--with-xpm-dir=/usr' '--with-zlib' '--with-zlib-dir=/usr'

  5. yeosteve
    Member
    Posted 3 years ago #

    Thanks, that got me searching and thinking.

    I tried
    SetEnv HTTP_MOD_REWRITE On
    in my htaccess, but that didn't work either
    Your config doesn't mention mod_rewrite either, but I read somewhere that mod_rewrite doesn't work if Apache is running as cgi

    echo php_sapi_name();

    gives me cgi-fcgi

    Will that be the problem, do you think?

  6. I know you can use WP with fcgi (though I don't like it, memory issues).... Okay.

    Try this. Add

    RewriteCond %{REQUEST_URI} !^/php5.fcgi

    just before the final

    RewriteRule . index.php [L]

  7. yeosteve
    Member
    Posted 3 years ago #

    Nope. That didn't sort out either issue. Maybe I should stop the server running as CGI, because I've had some memory problems too. What would you recommend?

  8. I would suggest using any PHP except fast CGI because of the mod_rewrite hassle and the memory stuff, but it's a personal decision. I don't like to hassle with it ;) Mind, I use DSO, which is also crazy in it's own way.

    That said, people I know and like love fastCGI because it's, y'know, fast ;) And plays well with nginx.

    What's your full .htaccess?

  9. yeosteve
    Member
    Posted 3 years ago #

    Just the basic
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteCond %{REQUEST_URI} !^/php5.fcgi
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic