multisite install re-login loop (15 posts)

  1. lyfstank
    Posted 6 years ago #

    I recently followed all the steps in setting up the multisite functionality on my blog. However, after I modify the .htaccess and wp-config files and it tells me to re-login, I get a login loop: I login, it just loops back to needing to login. I visit the blog itself and I get a message about a redirect problem. I have rejigged the files so that I have the blog back, but would love to get the multisite functionality working. Any ideas?

    I have tried, just so you know, disabling all my plugins, deleting all my plugins (after backing them up of course). That didn't seem to help.

  2. Did you clear your cookies and your cache? The setup requires you to login again, so sometimes things need to be flushed.

  3. lyfstank
    Posted 6 years ago #

    Yeah, I flushed everything and even tried different browsers.

  4. Got a link to your site?

  5. lyfstank
    Posted 6 years ago #


    however, I have reverted everything so that it's working as it was before. What else could I do for you?

  6. the /blog/ term got stuffed in the permalinks. Which it will do if it lets you pick subfolders.

    What host are you on?
    When you added the stuff to the config & the htaccess, did it have the www in there?
    (in the past, redirects happened with www & non)

    (whooo Toronna!)

  7. lyfstank
    Posted 6 years ago #

    so with the permalinks, what should I do?

    I am with DreamHost.
    Yes the www was there. I had to add some define() in the wp-config myself because I futzed something when setting up the network. It initially says, when you first enable multisite in config, that you should ideally have things without "www" and so I changed that in my settings and it kicked me out permanently. So I added the following two lines to my config to fix it,

    define('WP_SITEURL', 'http://www.stolteclan.ca');
    define('WP_HOME', 'http://www.stolteclan.ca');
  8. lyfstank
    Posted 6 years ago #

    p.s. Toronto rocks...except during the G20

  9. Ah, dreamhost. Have you talked to them? They disable the network from working on their shared accounts. :-/ make sure you have the right accountlevel before we run around in circles.

    p.s. Toronto rocks...except during the G20

    Yeah really. :-/ Peaceful day here on the East coast.

  10. lyfstank
    Posted 6 years ago #

    I haven't talked directly with them. My friend who set me up with them talks with them. I'll e-mail him and then let you know.


  11. TomWeissert
    Posted 6 years ago #

    Hi, I have a similar problem (looping login after enabling multisite). I think I'm getting close to the problem. Looking at the cookies that are generated, the path included with the login cookie after I enable multisite is different from the one before I enable, so I think the login is working but it is not able to read back the login cookie.

    I'm on a windows server with IIS. Here is are the lines I add to my config file for the multisite:

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/forkingpaths/blogs/';
    define( 'DOMAIN_CURRENT_SITE', 'forkingpaths.net' );
    define( 'PATH_CURRENT_SITE', '/forkingpaths/blogs/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    define( 'AUTH_SALT', 'mbEB5ysi,c?a5]@hcN06pCD|t}vYlE3;s@zGK|(+0PDz:O5_r>$13sX2oq3n*c' );
    define( 'SECURE_AUTH_SALT', '=i= XHzEKM.%CNV{2;dy :HQviWC`bxb|*5>PB5~|c.5e9Sg<^5|Jd.1xqR!V5Nt' );
    define( 'LOGGED_IN_SALT', 'G4|9@Eb>EiRJ=VO{XVJ!!dHNbXIf2g;1#s,LRao|9^P79P4<(0>S=.P>rA61u2E)' );
    define( 'NONCE_SALT', '(wl?$BU%clR<*jlm{;&yvQu|G@H&?,4:B)j[G!GHkv(Mw)^xi(6^?}8BX0bf&0' );

    before these lines are added, the cookie path is /blogs/ but afterwards, it becomes /forkingpaths/blogs/

    I tried changing the 'PATH_CURRENT_SITE' to /blogs/ but then I get a "can't connect to the database" error.

    If it'll help I can include the httpd.ini file (equiv of .htaccess)


  12. define( 'DOMAIN_CURRENT_SITE', 'forkingpaths.net' );
    define( 'PATH_CURRENT_SITE', '/forkingpaths/blogs/' );

    You can't run the network with the WordPress files in one directory, and the main URL showing the TLD. It has to be served from the folder it;s installed in.

    See the note here:

  13. TomWeissert
    Posted 6 years ago #

    I'm not sure I understand. the root directory of the domain forkingpaths.net is called /forkingpaths/
    The WP3 files are installed in a subdirectory of this root folder called /blogs/

    Thus the address of the blog is forkingpaths.net/blogs/
    and before I make the config change, all is well.

    What should I do?

  14. Thus the address of the blog is forkingpaths.net/blogs/

    But above your define( 'DOMAIN_CURRENT_SITE', 'forkingpaths.net' );
    is set to something different.

  15. Jay Hughes
    Posted 5 years ago #

    I'm running into the same issue with trying to set up multi site on my development server. (Windows IIS 7, 2008 mod_rewrite installed) using sub directories.

    In the wp-config.php, if I set the 'SUBDOMAIN_INSTALL' to false, it loops me through the log in. If I change it to true it allows me to login.

    Then I can switch it back and forth whilst logged in... but I get a 404 when creating my sub-directory.

    It's annoying because It would save me alot of time if I could get this going... any advice greatly appreciated.


Topic Closed

This topic has been closed to new replies.

About this Topic