• Resolved networkstudio

    (@networkstudio)


    Hi,
    it seems that only a network admin is allowed to save a Simply Gallery block. If the user is a simple administrator, an error occurs and the following message is displayed: “this block contains unexpected or invalid content”.
    Can you please check the issue?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author GalleryCreator

    (@gallerycreator)

    Hello,
    The gist of you issue is just that Network Admins are the only role on WordPress MultiSite with the unfiltered_html capability.

    To solve this problem you need to give simple administrator the right to publish “unfiltered html”. There are many plugins for editing user permissions. Unfortunately, I have no other solution to this problem. Or try version 1.1.4 (it is a bit simpler, but it should work with minimal rights too)

    There is a security issue that forces me to use a tag <script> to save gallery data. And this in turn creates problems for users of MultiSite that are not Network admins.

    Plugin Author GalleryCreator

    (@gallerycreator)

    return to version 1.1.4 will not help ((
    only unfiltered_html for simple administrator

    Hello,
    I used PublishPress to create a special role with unfiltered_html capability but the result is the same.

    Plugin Author GalleryCreator

    (@gallerycreator)

    Hello, try this version

    I added a couple of lines to the plugin to activate this permission for simple administrators. Just uninstall (delete) the normal version and install this one. I hope everything will work.

    Wonderfull! Thank you so much for providing a solution so quickly

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Multisite install’ is closed to new replies.