Support » Plugin: Migrate WordPress Website & Backups - Prime Mover » Multisite import not working for bbpress

  • Resolved jakobde

    (@jakobde)


    Hi,

    Thanks for a great plugin. I think your are really on to something.

    I tried your plugin to move a bbpress install to another multisite (or to be precise buddyboss – a fork of bbpress ) However i have some issue that groups, messages and user connections is not visible on the new multisite install after migration. Also the users profile pics is mixed up and users gets the profile pic of another users.

    I have noticed that somethings are actually in the new database like groups but for some reason that data is not showing up on the imported site.

    Have you tested the plugin with bbpress or do you have any idea what could be causing this?

    Br,

    Jakob

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Codexonics

    (@codexonics)

    Hi Jakob,
    Thanks for using Prime Mover plugin in moving your BBpress site. Yes the plugin is still have not fully tested with BBpress. However we assume that the core migration functionalities are there. For example, when a user is moved from one site to another, user IDs in users db table are adjusted as well. This includes the post authors ID in the post db table as well as user taxonomy (if applicable). But that’s it.
    BBpress could be storing user IDs in other fields or custom post metas that were not adjusted during the migration. So that’s the reason why some data could be mixed up. BBpress is included in our todo list of plugin compatibility testing and soon will be tested.
    If you are willing, can you please provide us the WPRIME package that you need to import? Please use our official bug support channel by logging in to WordPress admin -> Prime Mover -> Contact Us. Then provide us the link to download the WPRIME package for analysis.
    Then please add some details of the expected results of the migration so we can compare and check the data what needs to be auto-adjusted when migrating a BBpress site.
    Then we can close here and continue the discussion in our bug support channel. Hopefully the fix and adjustment can be added in coming releases. Thanks! 🙂
    Have a nice day! Cheers.

    Plugin Author Codexonics

    (@codexonics)

    Just to clarify I think BuddyBoss is a fork of BuddyPress instead of BBpress: https://www.buddyboss.com/buddyboss-vs-buddypress/

    So I remember before we tested BBpress (which is a forum plugin) and we don’t see much issues. I think this issue is on BuddyPress which is a social plugin for WordPress. BuddyBoss is a fork of BuddyPress.

    To reproduce this issue for now while the WPRIME package is not available, we will test using BuddyPress plugin. For your update. Thanks 🙂

    Thread Starter jakobde

    (@jakobde)

    Thanks for your in-depth answers. Sure i can provide you with the WPRIME package.

    Yes buddyboss is a fork but i suspect the issue is due to how BBpress stores meta och groups user data. This since i have read other treads about people using bbpress being unable to recreate groups and some data efter import. I.e they seem to experience the same issue as i do. But of course i cannot be 100% confident…

    Plugin Author Codexonics

    (@codexonics)

    Hi Jakob,
    Thanks for the package. Please give us time to look into this. We are aiming to include this in the next maintenance release as early as 2 weeks from now. But this will depend on the extent of testing and changes required 🙂
    If you don’t need anything else for now, you can close this ticket while we work on this feature request. Thanks.

    Thread Starter jakobde

    (@jakobde)

    Thanks for great support!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Multisite import not working for bbpress’ is closed to new replies.