Multisite Image path problem (12 posts)

  1. marcobjensen
    Posted 2 years ago #


    After updating to wordpress 3.5 all images on the multisites are broken.
    All images on the main site are working fine.

    The error occurs when for example this image is requested:

    I've checked the htaccess action, and it leads to this source:

    But the image is located at this path on the server:

    My htacess file looks like this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    I have read and tried so many other threads without luck. Im really hoping someone is able to help me out!


  2. What version of WP did you upgrade FROM?

    What you're seeing (in so far as URLs go) is not only correct, but it's what you always saw. Your image URLs were always /files/ translated to ms-files, and pulled from /blogs.dir

  3. marcobjensen
    Posted 2 years ago #

    I've been upgrading regularly since 3.1.1. The lates updates: 3.4.2 -> 5.3 -> 5.3.1

  4. Well it shouldn't magically break (and I'm betting if you rolled back to 3.4.x it would still be broken right now).

    Can you check if your httpd.conf has allowoverride set to either 'All' or 'Options All'?

  5. marcobjensen
    Posted 2 years ago #

    I'll ask my host about that. I dont have access to the httpd.conf (shared host).

    What should the value be? All or Options All?

  6. Options All is probably better for most hosts.

  7. marcobjensen
    Posted 2 years ago #

    It is set to AllowOverride All

    Any ideas then?

  8. Try Options All :)

  9. marcobjensen
    Posted 2 years ago #

    I just got my host to switch it to Options All. That did NOT solve the problem!

  10. :( Damn it. What host is this?

    JUST upgrading WP doesn't do this. Ever. It just ... can't. Have you turned off all your plugins to test if one of them is busted?

  11. marcobjensen
    Posted 2 years ago #

    The host is a danish one; http://www.danhost.dk

    I guess you're right about upgrading not being the reason why!

    Yes I have tried disabling all plugins.

    Do you have any other ideas or resources to go to?


  12. You could TRY reinstalling 3.4.... whatever the last one was. Overlaying the files.

    Past that, I'd see if you could change the ms-files dependancy and stop using it:


    You should never HAVE to do this, but in your case, it might be worthwhile.

Topic Closed

This topic has been closed to new replies.

About this Topic