[resolved] Multisite Host Transfer Domain Changing (14 posts)

  1. leosampieri
    Posted 2 years ago #

    Hi, everybody.
    I've copied the files from belgranostudio.com.ar (and my old webhost), to belgranostudio.com (the primary domian in Justhost, my new webhost). I moved all files and databases. All databases' names and users, remain the same.
    Then I changed a line in wp-config (in the new webhost, of course):
    "define( 'DOMAIN_CURRENT_SITE', 'www.belgranostudio.com' );"
    (it was set on .com.ar).

    When I try to browse http://www.belgranostudio.com, I get "This webpage has a redirect loop", on Chrome; "The page isn't redirecting properly", on Firefox; and the URL field shows: http://www.belgranostudio.com/wp-signup.php?new=www.belgranostudio.com

    Any ideas on how I should correct and finish the process?.
    What should I do with the .com.ar DNS's?.

    Thanks a lot !

  2. leosampieri
    Posted 2 years ago #

    I've manually changed siteurl and home options, in wp_options table, both pointing to the ".com" extension;
    I'm still getting the error message.

  3. leosampieri
    Posted 2 years ago #

    And finally, changed:

    Following this instructions:

    It's up again!.
    Now I have two twin sites, on .com.ar, and .com
    I've set the .com.ar extension as 'parked', in the justhost's domain manager. Should I set the justhost's DNS's for this domain?.

    Thanks !!

  4. leosampieri
    Posted 2 years ago #

    Still having problems.
    Can't access the newtwork sites,
    for ex. http://online.belgranostudio.com/

  5. Error is not multisite, error is your server.

    http://online.belgranostudio.com/ is a chrome error saying "Hey, this domain name doesn't exist."

    Check out http://www.whatsmydns.net/#A/online.belgranostudio.com vs http://www.whatsmydns.net/#A/belgranostudio.com

    You need to add wildcard subdomains to your new server and, if you also have new nameservers, you may need to set that up there too.

  6. leosampieri
    Posted 2 years ago #

    Mika, thanks a lot.
    I'll try it and let you now.

  7. leosampieri
    Posted 2 years ago #

    OK. So I've set up the wildcard with no problems.
    It has improved a bit the situation, but I'm still having trouble accesing the dashboards of the subsites, and the subsites themselves. BUT, if I place the 'www.' in the URL, I get a default Justhost blank screen. If I don't, I get the 'Server not found' error.
    I suppose this has nothing to do with the DNS.

    I've been reading that this may be an htaccess issue, so I place it here; hope it helps:

    # BEGIN s2Member GZIP exclusions
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteBase /
    	RewriteCond %{QUERY_STRING} (^|\?|&)s2member_file_download\=.+
    	RewriteRule .* - [E=no-gzip:1]
    # END s2Member GZIP exclusions
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    Thanks you all.

  8. leosampieri
    Posted 2 years ago #

    I tried disabling all the plugins, but it didn't work.

  9. leosampieri
    Posted 2 years ago #

    I've consulted Justhost, and they've found nothing strange on their side.

  10. http://online.belgranostudio.com/ loads (yay) but points to JustHost.

    So you didn't do wildcards right on your sevrer now.

    Ask JustHost "How do I make it so anything.belgranostudio.com will load from the belgranostudio.com folder?"

  11. leosampieri
    Posted 2 years ago #

    Hi, Mika,
    thanks again.
    I believe I did set the wildcards, using this instructions from the Help section:
    To create them follow these steps:
    Login to your Just Host Control Panel
    Click the Subdomains icon, located in the Domains section.
    In the "Subdomain" name field, enter the "*" character. (Shift + 8)
    Leave the "Document Root" set to default.
    Select "Create".

    And in the cpanel subdomain section I got:
    Subdomains: *
    Root Domain: .belgranostudio.com
    Document root: /public_html/wildcard
    Redirection: not redirected

    I'll ask Justhost what you said anyway.
    Thanks !.

  12. leosampieri
    Posted 2 years ago #

    Perhaps it's useful to say that I've been using the site you sent me:
    and no matter wich subdomain I try (even non existing subdomains, like aaa.belgranostudio.com), they all seem to be pointing to justhost (all green lights mostly).
    I've tried to make a new subsite, and I'm getting the same errors as the others already existant.

  13. leosampieri
    Posted 2 years ago #

    So this is what happened,
    when I set the subdomain wildcards, the justhost cpanel (by itself) placed the term 'wildcard' in Document root: /public_html/wildcard
    So, I found a folder called 'wildcard' in my root.
    I deleted that setting and made a new one, erasing this word 'wildcard'.

    Everything is up and running.
    All the sites and dashboards are just fine.

    For everyone else trying to do this, I recommend following this instructions: http://halfelf.org/2012/moving-wordpress-multisite/,
    written by Mika. (I skipped the step where she says: "edit all wp_posts (and wp_x_posts) tables with a search/replace of your domain name", but perhaps I'll have to do it in the future).

    Mika, THANKS!.

  14. leosampieri
    Posted 2 years ago #

    Finally I did the replacement in the wp_x_posts tables,
    with this plugin:
    You have to do it from the dashboard of each subsite > tools > search and replace.

    Everything seems to be working.

Topic Closed

This topic has been closed to new replies.

About this Topic