WordPress.org

Forums

WooCommerce Video Product Tab
[resolved] Multisite: Have to install Woocommerce (4 posts)

  1. Schelte
    Member
    Posted 2 years ago #

    Hi,

    I'd like to install this plugin in a multisite environment.

    After installing the plugin, I get the following error:
    "WooCommerce Video Product Tab requires WooCommerce to be activated in order to work. Please install and activate WooCommerce first."

    Is it right that this plugin is not compatible in a multisite environment? If it is, does anyone know how I get the plugin working?

    Thanks in advance.

    http://wordpress.org/extend/plugins/woocommerce-video-product-tab/

  2. Sebastien Dumont
    Member
    Plugin Author

    Posted 2 years ago #

    Yes I do understand that there is a problem with my plugins on multi-site environment.

    I will be updating this plugin and all other WooCommerce plugins of mine with a new piece of code that will replace what currently detects if WooCommerce is active for a single site environment.

    This is the current code in use.

    // Checks if the WooCommerce plugins is installed and active.
    if(in_array('woocommerce/woocommerce.php', apply_filters('active_plugins', get_option('active_plugins')))){

    This is the new code I will use.

    // Query whether WooCommerce is activated.
    if(!function_exists('is_woocommerce_activated')){
    	function is_woocommerce_activated(){
    		if(class_exists('woocommerce')){
    			$is_woocommerce_active = true;
    		}
    		else{
    			$is_woocommerce_active = false;
    		}
    		return $is_woocommerce_active;
    	}
    }
    
    /* If WooCommerce is active then we load the plugin. */
    if(is_woocommerce_active()){
    /* Plugin code is here. */
    }
  3. Sebastien Dumont
    Member
    Plugin Author

    Posted 2 years ago #

    Please can you try this version and let me know if it works ok.

    http://downloads.wordpress.org/plugin/woocommerce-video-product-tab.2.3.2-beta.1.zip

    Your feedback will be most helpful.

    Thank you.

  4. Sebastien Dumont
    Member
    Plugin Author

    Posted 2 years ago #

    I just noticed the type error.

    It should be if(is_woocommerce_activated()){

    Updated the beta file.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce Video Product Tab
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.