Support » Plugin: Next Active Directory Integration » Multisite: getOptions don’t work sometimes

  • I use a multisite installation and after configuration i tried to login but it didn’t work. After searching in the logs and the code i found out, that the account suffix got not read from the database and the plugin tried to authenticate the users without the suffix. If i set the account suffix directly in the code, it works.
    After Authentication with the help of this hack i find out that the user wasn’t created in the wordpress data base because of the same reason: the “autoCreateUser”-variable was empty, like the account suffix before.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author tobi823

    (@tobi823)

    Hi wordpressrene

    are the option values like “account suffix” still visible after a page reload? Can you verify that the option values are stored correctly?

    Hi tobi

    yes the options are visible in the backend after a page reload. As far as i can see the values are stored correctly in the table “site_meta”.
    Further i found the same problem with the value of “is sso enabled”

    Plugin Author tobi823

    (@tobi823)

    Hi wordpressrene,

    I suppose that you enter your configuration on the “profile options” page (wp-admin/network/admin.php?page=next_ad_int_profile_options)? If yes, then:

    – change the permission for every profile option to “Deactivated and option value shown.”
    – assign your profile to your blog/site (where you tried to login)

    On default only the options from the blog configuration (like wp-admin/admin.php?page=next_ad_int_blog_options or seite2/wp-admin/admin.php?page=next_ad_int_blog_options) will be used for login, Sync to WordPress, e.g.

    By changing the permission from “Blog admin sets the option value.” to “Deactivated and option value shown.” you enforce your configuration on every blog/site which is assigned to this profile.

    If that not help, please send me your wp-content/plugins/next-active-directory-integration/log/debug.log to the@neos-it.de.

    • This reply was modified 3 years, 10 months ago by tobi823.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Multisite: getOptions don’t work sometimes’ is closed to new replies.