Support » Plugin: Slider, Gallery, and Carousel by MetaSlider - Responsive WordPress Plugin » Multisite – Error fetching list of slideshows

  • Resolved plarkin

    (@plarkin)


    Unlike others, my WordPress Multisite is NOT updated to 5.x but it is still on 4.9.13.

    I have a Multisite with 33 sub-sites. Oddly, I have tested 6 or so and have found 4 perfectly fine and 2 sites exhibiting the error.

    Error fetching list of slideshows: Not Found (404)

    This may not be the same issue as others. Any suggestions on how to troubleshoot this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi,

    If the route endpoint isn’t found, that means there’s an issue with WordPress.

    I’ll have a fix for this in the next release (early January), but if you want to old way of delivering data you can force it by adding this constant to wp-config.php

    define('METASLIDER_FORCE_ADMIN_AJAX', true)

    Let me know if that works.

    Hi @kbatdorf (@kbat82)

    Thank you so muck. It’s working for me

    Thanks

    This same problem cost me about 12 hours of work. First scouring the database for errors, thinking that changing the metaslider theme may have conflicted with themes in social media plugins. Then changing an ajax setting in one of those plugins. Then reviewing another site I have on a different multi-site network with same theme and where metaslider admin works. Then disabling all plugins. Then searching support topics and finding this. It’s past early January and I have the latest version. Old admin worked fine. Not sure why you had to change it. When will the fix be coming out and how will it solve the problem?

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @madriverweb

    Not sure why you had to change it

    Continuously adding new features requires refactoring many parts of the system.

    When will the fix be coming out and how will it solve the problem?

    I’m not adding a “fix” but instead adding a workaround (the above snippet is also a workaround) for those with either misconfigured servers, or issues where other plugins have broken parts of the user’s site. i.e. It’s not an issue with MetaSlider specifically but a change I made exposed other issues that some users are having. In the original post here, a REST route is returning a 404, which should not happen on WordPress (WP requires a working REST implementation).

    If you’d like to debug those other issues I’m more than happy to help. Just open a new issue and we can go through the steps.

    https://wordpress.org/support/plugin/ml-slider/#new-post

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Multisite – Error fetching list of slideshows’ is closed to new replies.