Support » Plugin: Custom Admin Page by BestWebSoft » MultiSite Error

  • After the most recent update, highly problematic database errors were caused in our multisite installation.

    First, there are a large number of errors , one per sub-site table it looks like, of the following form:

    [16-Jan-2020 03:43:50 UTC] WordPress database error Incorrect table name ” for query SELECT * FROM wpyp_37_cstmdmnpg_pages made by require_once(‘wp-admin/admin.php’), require(‘wp-admin/menu.php’), require_once(‘wp-admin/includes/menu.php’), do_action(‘admin_menu’), WP_Hook->do_action, WP_Hook->apply_filters, cstmdmnpg_add_pages, cstmdmnpg_remove_old_table, cstmdmnpg_transfer_data
    [16-Jan-2020 03:43:50 UTC] WordPress database error Incorrect table name ” for query SELECT * FROM wpyp_38_cstmdmnpg_pages made by require_once(‘wp-admin/admin.php’), require(‘wp-admin/menu.php’), require_once(‘wp-admin/includes/menu.php’), do_action(‘admin_menu’), WP_Hook->do_action, WP_Hook->apply_filters, cstmdmnpg_add_pages, cstmdmnpg_remove_old_table, cstmdmnpg_transfer_data

    The series caps off with the following:

    [16-Jan-2020 03:43:50 UTC] WordPress database error Incorrect table name ” for query DROP TABLE IF EXISTS wpyp_cstmdmnpg_pages, wpyp_7_cstmdmnpg_pages, wpyp_14_cstmdmnpg_pages, wpyp_15_cstmdmnpg_pages, wpyp_16_cstmdmnpg_pages, wpyp_17_cstmdmnpg_pages, wpyp_18_cstmdmnpg_pages, wpyp_19_cstmdmnpg_pages, wpyp_20_cstmdmnpg_pages, wpyp_21_cstmdmnpg_pages, wpyp_22_cstmdmnpg_pages, wpyp_23_cstmdmnpg_pages, wpyp_24_cstmdmnpg_pages, wpyp_25_cstmdmnpg_pages, wpyp_26_cstmdmnpg_pages, wpyp_27_cstmdmnpg_pages, wpyp_28_cstmdmnpg_pages, wpyp_29_cstmdmnpg_pages, wpyp_30_cstmdmnpg_pages, wpyp_31_cstmdmnpg_pages, wpyp_32_cstmdmnpg_pages, wpyp_33_cstmdmnpg_pages, wpyp_35_cstmdmnpg_pages, wpyp_36_cstmdmnpg_pages, wpyp_37_cstmdmnpg_pages, wpyp_38_cstmdmnpg_pages; made by require_once(‘wp-admin/admin.php’), require(‘wp-admin/menu.php’), require_once(‘wp-admin/includes/menu.php’), do_action(‘admin_menu’), WP_Hook->do_action, WP_Hook->apply_filters, cstmdmnpg_add_pages, cstmdmnpg_remove_old_table

    In order to restore full functionality to the installation, we had to disable the plugin. After reactivation, the main symptomatic behavior – disruption of normal login to the main site – immediately recurs.

    • This topic was modified 6 months, 3 weeks ago by CK MacLeod.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Errors most likely occur due to the installation of the plugin as a subsite, and then for some reason, they activated the plugin for all domains through the multisite admin panel. Due to the lack of the necessary tables, db errors began to appear.

    We took into account and fix this bug in the next versions. We advise you to activate the plugin on each subsite separately and there should be no errors.

    Feel free to contact our support team with any questions in future. For more convenience, you can do it via our Help Center (https://support.bestwebsoft.com/) in order to receive a faster reply.

    Eugenia
    BestWebSoft

    Thanks for your reply, but I just thought I’d let you know that, when I activate the plugin at the main site – not network-activated – I immediately get redirected to a sub-site dashboard. When I activate the plugin at any other sub-site, I do not have that same problem.

    If I network-activate the plugin, I am able to access the main site dashboard, but I get timeouts and have other issues accessing the subsite dashboards – though I do not log new errors. I do not know if this latter problem or set of problems has to do with some other installation issues, but I do know that when I de-activate the plugin, the issues go away.

    Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Thank you for explaining all the nuances of the error, we will check it and fix this in the next plugins updates.

    Feel free to contact our support team if you need any assistance.

    Eugenia
    BestWebSoft

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘MultiSite Error’ is closed to new replies.