Support » Networking WordPress » Multisite, Domain Mapping, SSL

  • Resolved teeray


    I’ve been struggling with this for some time, so apologies for the cross post.

    I have a simple multisite set-up with mapped domains and SSL (using the wordpress https plugin). Each mapped domain has their own security certificate purchased. I have installed them and set the https plugin to use the SSL for the correct domain.

    SSL is working perfectly for one domain – and it’s a disaster for the other. The one which doesn’t work is constantly redirected to http. I can’t enter secure filters because they get zeroed out. And the HTTPS domains in the network admin all keep changing to the default url as soon as they’re saved.

    I’d love some guidance on how to fix this, if anyone’s encountered this issue before or has some troubleshooting suggestions.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    The only thing I remember simialr is this:

    (BTW, you don’t have to tag it with my name – I’m checking in as much as I can, but there’s some family stuff going on so you gotta be patient)

    Apologies for the tag – totally understood on the family issues. No lack of patience here, especially since this has been an issue I’ve been trying to fix for a month. I just know that this is your side-gig and since this was posted a few days ago, figured it might have gotten lost in the mix.

    I’ve actually read that thread you posted and just about every other one on the same/similar issue. The thing is, one of the domains is working just fine. Perfectly. The other one is just redirecting back to HTTP. It’s a total mystery.

    Apache entries have been checked, so has domain mapping. This seems to be purely an issue with multisite and the https plugin…and since there’s a sore lack of support over there on the https forum, I have no opportunity to hound the experts over here.

    Again, apologies – NO serious nagging was intended.

    @teeray, one question, have you installed the plugin Network-wide? Have you tried to instal it in every web site separetely and see if it works?

    Another thing, I’m not totally sure, but you could use one SSL Certificate with WildCard. Or am I wrong?

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    One thing isn’t clear.., you say only one domain isn’t working. Is that the only mapped domain where you’re using SSL?

    Honestly, I’ve never tried it myself. I did use SSL for admin without issues, though.

    Hi Renato,

    Thanks! It doesn’t seem to matter whether I network activate the plugin or activate it on individual sites – the result is exactly the same.

    Curiously, after a while, the https domains in the plugin seem to reset themselves. Meaning when I go back, they’ve all changed to the primary domain url (which itself has an SSL installed).

    This seems to have no impact on one of the sites. But on the other one, https is just not working at all.

    @ipstenu: nope. I’m using SSL on two mapped domains as well as the primary domain. The primary and one mapped domain are working, though I care little about the primary domain as it has nothing to secure.

    So it’s not working on one of the mapped domains, but is on the other. It’s so strange.

    One thing I know is that the https plugin definitely isnt working as it should – it completely zeroes out information and defaults back to the primary domain. I can’t even use url filters to always secure as they don’t save properly. I’ve tried reinstalling the plugin a dozen times. Nothing.

    I’m debating migrating the current site to a new installation to test it but it’s going to be a nightmare. It’s not a small site. And I feel like it will still cause a repeat of the problem.

    @teeray, it seems this https you are using is the cause of the problem.. Try a different one or as you say, create a testing environment and test it.

    Definitely sounds like an issue with the https plugin, not Multisite, but could be wrong. Maybe find another https plugin solution?

    Thanks everyone.

    The other https solutions I’ve tried have caused some major issues with the site. They’ve messed up redirections and more. It seems like even when the https plugin is removed, there are some settings there that are still causing the domain to redirect to http.

    Does anyone have any insight on what to do to make sure that all the https settings are completely reset?

    There might still be tables left in your database from this plugin, so even if you remove it, there may remain traces. Also, your .htaccess file has most likely changed with this plugin, and even after disabling it, the .htaccess file may remain the same, thus causing issues.

    Thanks, WP4RE.

    I’ve gona ahead and removed the plugin, checked the .htaccess – no rewrite rule pertains to https (it’s pretty much the default for multisite).

    I’ve also gone into the db and deleted all entries in each wp_options table for each site that relates to the https plugin.

    Even when the plugin is disabled, https:// on the site redirects to http://. It does it just for that one site – not for the others.

    So SOMETHING is causing this. The trick right now is finding exactly what.

    Any ideas?

    Thanks everyone for your help. After countless weeks and hours trying to work out what was wrong, it was very simple.

    The site had woocommerce instead, and it was set to revert to http on checkout. This seems to actually force ALL https pages throughout the site to forward back to http, not just the pages that you visit after checkout.

    Unchecking that solved the problem. It was so simple I can almost hit myself, but thankfully it’s now resolved!

    Awesome! I took a course of a few days back about working with Woocommerce and that’s true.

    It seems only the checkout pages are important to have HTTPS because it’s over there where the real information are transfered.

    Glad you found the solution. =)

    Hi teeray, I’m trying to do exactly the same as you. So i have 1 master site and loads of sub sites using sub domains and domain mapping. Got it all working perfectly. But i would like the make a couple of pages on all the sites https so I’ve got an SSL.

    When you managed to do it, did you use a regular SSL or a wildcard one? and did you have all the sites under the same i.p?

    Thanks in advanced.

    Hi there,

    I used separate regular SSLs for each domain. All the sites were under the same IP.

    Hope that helps.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Multisite, Domain Mapping, SSL’ is closed to new replies.