Support » Fixing WordPress » Multisite – Domain mapping || Second domain gets redirected to first domain

  • Resolved luftikus143


    ok, after many, many hours of trying around and reading tutorials, i slowly start to understand. But not yet completely.

    I have successfully managed to turn my existing (german) wordpress installation ( into a multisite. I want to create a second blog (english), which would run through

    So, german blog under

    I’ve added a new wordpress site (“test”) which corresponds to It works.

    In the “Network admin”, the “Domain mapping” points to “” (I don’t have an IP).

    In the “test” admin area, I click on “Domain mapping”, “add new domain” and enter, as primary domain.

    Now, there is something I have to do on the webhosting administration side. I can change the domain attribution, so that gets redirected to

    But when I do this, my get’s indeed redirected to, but not And gets redirected to

    What am I doing wrong? Thanks so much for any hints!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi luftikus143

    Please go through the post below.
    and check if you are doing everything right.

    Hi Maruti. Thanks, and yes, it was one of those pages which I consulted before, even a couple of times.

    Meanwhile, at least the redirection from to works. Must have been a DNS issue.

    However, the “domain mapping” doesn’t work. When I enter “” into the “Add new domain”, and I enter then the into my browser, I can see that it redirects (as before) to, tries to load it, but doesn’t succeed (“Failed to open page”).

    Any idea?

    Hi ,

    In the domain mapping page you need to check if you have entered the right IP address and then in the domain options check 2nd n 3rd option.

    You dont need to change anything here anymore when you add sites.
    To add sites go the admin network and add sites.

    For example if ur parent site is and the new site you want to add is site1 then in the “Add new site” in the site address field just add site1 and other details.
    then the url would be or depending upon the installation.

    Now if you want to do the domain mapping, go to settings->domains
    In the new domain field add the site id(site1 id, you can get this by hovering over the site in all sites)
    then give the domain name of ur choice lets say “” and then check the primay and save

    Hope this helps

    As far as I can judge, I’ve done it the same way you describe. However, and here I come back to the first post, the browser is saying “Too many redirects occurred trying to open “”.

    As I don’t have the IP address, I enter the URL instead in the Domain Mapping: “”.

    It doesn’t make a difference if it’s “” or “”, right?

    yes but in the domain mapping you need to provide the ip of the server you have hosted your site in.

    If you dont have it please contact your host provider and get it.

    It would remain same for any number of sites you add. It just points to the server.

    But it says on the domain mapping page that one can enter either the IP or the CNAME. In my case, the host provider said that the IP links to a virtual server with many domains. So, I can’t use the IP.

    fine then use the CNAME but the CNAME should point to ur server.

    Yup, as I wrote above,

    “In the “Network admin”, the “Domain mapping” points to “” (I don’t have an IP).”

    That should do it, no?

    Resolved. I had to point the second domain in the host provider’s admin part to the PATH /www/site1, not to the URL.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Multisite – Domain mapping || Second domain gets redirected to first domain’ is closed to new replies.