Support » Networking WordPress » Multisite Domain Mapping 404 error

  • Hello,

    I have a WordPress Multisite install. I have the primary domain as 131atlanticave.com and now want to add another website with a unique domain name, 365atlanticave.com. I have added it as an addon domain for a domain name I purchased through my web hosting company. Subdomain 365atlanticave.com.131atlanticave.com on my cPanel account. The is an A record for 365atlanticave.com pointing to the servers shared IP 68.66.248.19(I don’t have a dedicated IP).
    The primary domain has the WordPress multisite install in a sub directory, public_html/131atlanticave.com/

    In WordPress Multisite I added a new website; >Sites > 365atlanticave.com > Settings under Site Address (URL): https://365atlanticave.com/

    The primary Domain works no bother 131atlanticave.com
    365atlanticave.com returns a 404 not found error.

    My hosting provider hasn’t been much help so I hope to I have better luck here.

    Kind regards

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello,

    Both domains are returning 403 – Forbidden.

    You need to fix that before you can proceed any further.

    Also…

    The primary domain has the WordPress multisite install in a sub directory, public_html/131atlanticave.com/

    While this setup is possible, it requires a lot of tweaks and is likely to give you a lot of headcaches down the road with some plugins even after getting it working now.

    From the Before You Create A Network page:

    WordPress should be run from the root of your webfolder (i.e. public_html) for subdomains to work correctly. Making subdomains work from a non-root directory requires experience with Virtual Hosts and redirects.

    I have resolved the issue. I will explain to help others.
    In cPanel under Addon Domains create your addon domain for example website1.com. This is crucial, point it to your WordPress Multisite install for the document root. So my Multisite install is located in subdirectory public_HTML/prioritysite.com.
    So my ‘document root’ for website1.com is public_HTML/prioritysite.com because that is where my WordPress Multisite install is.

    In WordPress Multisite; > Sites > website1.com > Settings under Site Address (URL): https://website1.com/

    Once that is sorted, your will try to login into the backend of website1.com/wp-admin/ you will get a cookie error. Add this line after the other code you added to create the network in the wp-config.php file:

    define(‘COOKIE_DOMAIN’, $_SERVER[‘HTTP_HOST’]);

    I imagine you’ll be adding other properties over time so don’t forget you might use sub-domains there to save the hassle (expense) of purchasing discrete domain names.

    Since you have this working well now, I’ll stay out of this except to suggest you add the Broken Link Checker plugin and enable it on each subsite.

    https://wordpress.org/plugins/broken-link-checker/

    That plugin will quickly point out any permalink issues and actual broken links. It can be a resource hog though so once it’s traversed the whole site once you can throttle it back to 480 hrs from its native 72 hr setting. The rest of the settings are mostly a convenience tweak to select how it handles broken links and uses various means to check certain links such as Youtube videos.

    If you need anything else, feel free to come back and ask.

    I have been trying to talk my client into the sub domain route. But he is dealing with ‘unique’ clients with homes in the market for an average 4 million USD. 131 Atlantic Ave is 7.2 million. Clients like that are hard to convince that their extravagant home doesn’t warrant their own domain name lol…
    Thanks a mill for the broken link checker link! I will give that a go.

    @damhnait your explanation of how you resolved the issue is an absolute life saver. Well, at least a tremendous time saver. I don’t use cPanel, rather Plesk, but it’s essentially the same idea. I just had to install the subdomain web space at the root of the primary domain for the Multisite setup. So I installed primarydomain.com/subfolder at root/https and it FINALLY worked. I’ve been pulling my hair out about this for the last 24 hours. Thank you so much!

    @mattsingley Oh thats lovely! I am relieved my explanation could be understood as intended and actually help someone. I was surprised how little documentation was available for this specific issue. It’s one of those issues you think you’ll solve in 2 hours but turns into your whole day. Annoying so it is! Best of luck.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.