Support » Plugin: Really Simple SSL » Multisite deprecated function “wpmu_new_blog” generates white error page

  • Resolved masterbip

    (@masterbip)


    Errores:

    Deprecated: wpmu_new_blog ha quedado obsoleto desde la versión 5.1.0. Utiliza wp_insert_site en su lugar. in /home/tiendavi/public_html/wp-includes/functions.php on line 5088

    Warning: Cannot modify header information – headers already sent by (output started at /home/tiendavi/public_html/wp-includes/functions.php:5088) in /home/tiendavi/public_html/wp-includes/pluggable.php on line 1281

    Warning: Cannot modify header information – headers already sent by (output started at /home/tiendavi/public_html/wp-includes/functions.php:5088) in /home/tiendavi/public_html/wp-includes/pluggable.php on line 1284

    Searching on plugin I found:
    class-multisite.php on line 68:
    add_action(‘wpmu_new_blog’, array($this, ‘maybe_activate_ssl_in_new_blog_deprecated’), 10, 6);

    Maybe there is the error?

    How to fix it?
    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • By the way all the “if” is commented
    from line 64 to 70 line except line 68

    //If WP version is 5.1 or higher, use wp_insert_site hook for multisite SSL activation in new blogs
    //if(version_compare(get_bloginfo(‘version’),’5.1′, ‘>=’) ) {
    // add_action(‘wp_insert_site’, array($this, ‘maybe_activate_ssl_in_new_blog’), 20, 1);
    //} else {
    add_action(‘wpmu_new_blog’, array($this, ‘maybe_activate_ssl_in_new_blog_deprecated’), 10, 6);
    //}
    //Listen for run_ssl_process hook switch

    If I “uncomment” this i got another warning and a white error page:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘rsssl_multisite’ does not have a method ‘maybe_activate_ssl_in_new_blog’ in /home/tiendavi/public_html/wp-includes/class-wp-hook.php on line 287

    Warning: Cannot modify header information – headers already sent by (output started at /home/tiendavi/public_html/wp-includes/class-wp-hook.php:287) in /home/tiendavi/public_html/wp-includes/pluggable.php on line 1281

    Warning: Cannot modify header information – headers already sent by (output started at /home/tiendavi/public_html/wp-includes/class-wp-hook.php:287) in /home/tiendavi/public_html/wp-includes/pluggable.php on line 1284

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    Hi @masterbip,

    Thanks for the feedback.

    These are deprecated notices, not errors as such. You can safely ignore them. It’s on the list to get changed.

    The commented lines are not meant to be uncommented. That’s unfinished code.

    On a live site I would recommend to disable WP_DEBUG.

    I expect the change to the newer “wp_insert_site” hook to be included within 4 weeks.

    Plugin Contributor Mark

    (@markwolters)

    @masterbip the 3.3.4 update contain now uses the new wp_insert_site hook.

    Mark

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.