• Resolved taropaa

    (@taropaa)


    Hi This plugin is having some issues in multisite, when running with elementor and autooptimize.

    Autooptimize Settings Are:

    Extra > Google Fonts – Remove Google Fonts

    CAOS Webfonts Settings Are:

    Save Webfonts to: /cache/caos-webfonts
    Serve fonts from CDN: cdn.###.io
    Font Display Option: Auto (default)
    Enable preload for stylesheet (experimental): yes

    WP v 5.1.1 – Multisite (subdomain)
    CAOS for Webfonts 1.7.6
    Autoptimize – 2.4.4
    Cache Enabler – 1.3.3
    Elementor – 2.5.9
    Elementor Pro – 2.4.8

    PHP 7.2.13
    memory_limit – 2048M
    Wordpress Memory Limit – 64M

    The Elementor Page Builder takes a lot of time to load and Google Fonts are not being loaded.

    The javascript console does not show any 404 errors for the live page and the fonts are being loaded within the Elementor Page Builder.

    The Error I am getting in the error-log is:
    Webtemple database error Table ‘wp_12_caos_webfonts' already exists for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'elwlbranding_settings' AND site_id = 1 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), WP_Hook->do_action, WP_Hook->apply_filters, hwlRunDbUpdates, hwlCreateWebfontsTable\nPHP message: Webtemple database error Table 'wp_12_caos_webfonts_subsets' already exists for query CREATE TABLE wp_12_caos_webfonts_subsets (\n subset_font varchar(32) NOT NULL,\n subset_family varchar(191) NOT NULL,\n available_subsets varchar(191) NOT NULL,\n selected_subsets varchar(191) NOT NULL,\n UNIQUE KEY (subset_font)\n ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_520_ci; made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('plugins_loaded'), WP_Hook->do_action, WP_Hook->apply_filters, hwlRunDbUpdates, hwlCreateSubsetsTable\n', referer: https://####/wp-admin/post.php?post=####&action=elementor
    (I redacted URL’s and I have a custom database prefix which for security reasons I will not disclose.)

    Did I misconfigure a setting or is this a bug?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Changed

    Font Display Option: Swap
    Enable preload for stylesheet (experimental): no

    Fonts are now loading and swapping on the home page, but I am getting the DB error in the logs still for wp-admin page I visit.

    Plugin Author DaanvandenBergh

    (@daanvandenbergh)

    @taropaa,

    For some reason, the plugin was unable to correctly write the database version of CAOS for Webfonts to your wp_options table.

    Try doing the following:

    Lookup the row in the wp_options table with the option_name value caos_webfonts_db_version. If it doesn’t exist: create it and change the option_value value to 1.7.0.

    Let me know if that helped.

    Also, could you tell me if in a Multi Site setup, every WordPress install has a different prefix for each database table? Cause if so, this might be a coding error on my behalf.

    Hi @daanvandenbergh, I checked and the option is correctly set.
    I have a custom table prefix which is the same across the entire site.

    Each site in a multisite install has its own wp_options table. With the custom prefix, it would be custom_XX_options instead of wp_XX_options, where the XX is the Site ID.

    Plugin Author DaanvandenBergh

    (@daanvandenbergh)

    Okay. Thanks for the info.

    Yes, the plugin keeps in mind a custom table prefix, but it doesn’t keep in mind the site ID.

    So, thanks for notifying me! I’ll release an update shortly!

    Plugin Author DaanvandenBergh

    (@daanvandenbergh)

    @taropaa, this bug should be fixed in version 1.7.7. Let me know how it goes!

    Yup, that did the trick! Thank you for the quick reply and fix!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.