Support » Networking WordPress » Multisite crash after update

  • I have our WP install set-up as a multisite with Domain mapping. Site and mapping was working great in version 3.3, of course I backed up the database before updating to version 3.4.1. After the update to the new version my main site worked fine, but my one network site gave me this error -> Error establishing a database connection
    Then, when I log into the admin and I was prompted to repair the site so I ran the repair and got this:
    wp_2_posts: Table ‘bra1202410323917.wp_2_posts’ doesn’t exist
    wp_2_comments: Table ‘bra1202410323917.wp_2_comments’ doesn’t exist
    wp_2_links: Table ‘bra1202410323917.wp_2_links’ doesn’t exist
    wp_2_options: Table ‘bra1202410323917.wp_2_options’ doesn’t exist
    wp_2_postmeta: Table ‘bra1202410323917.wp_2_postmeta’ doesn’t exist
    wp_2_terms: Table ‘bra1202410323917.wp_2_terms’ doesn’t exist
    wp_2_term_taxonomy: Table ‘bra1202410323917.wp_2_term_taxonomy’ doesn’t exist
    wp_2_term_relationships: Table ‘bra1202410323917.wp_2_term_relationships’ doesn’t exist
    wp_2_commentmeta: Table ‘bra1202410323917.wp_2_commentmeta’ doesn’t exist

    What I tried:
    • Restoring the backup and it did not solve the problem.
    • Andrea Rennick suggested in her creating a WordPress Network that if you get the Error establishing a database connection, it usually means the extra tables were not created. She suggested making sure the database user has ALL permissions on the database. So I contacted my host ( to check SQL permissions to make sure I can create tables and they said they could not tell me where or how to set the permission – I was not able to find the permission setting myself. Ugh.
    • I also just tried to add another site to the network and I could not, I got this error: Missing or invalid site address.

    So at this point I am not sure how I should approach fixing this mess? I think I am over my head with this one.

Viewing 4 replies - 1 through 4 (of 4 total)
  • First step is to go into your DB and see if those tables actually exist.

    You may need to run a repair of the DB via phpMyAdmin, or whatever it is that GoDaddy uses.

    Thanks for the input Mike,

    I checked the DB and there are no wp_2_…. tables only the default wp_… tables. I am going to look around GoDaddys site to see if I can figure out how to repair the DB. I clicked on the phpMyAdmin tool and it launched the home view -it looks like they use a tool called Starfield technology – which unfortunately looks nothing like phpMyAdmin that I have worked in some in the past. The link to documentation is broken in the tool so I am going to do some research.

    Make sure Line 2 shown below exists in wp-config.php

    1: define('WP_ALLOW_MULTISITE', true);
    2: define('MULTISITE', true);
    3: define('SUBDOMAIN_INSTALL', false);
    4: $base = '/<YOUR_DIRECTORY>/';
    5: define('DOMAIN_CURRENT_SITE', '<YOUR_URL>');
    6: define('PATH_CURRENT_SITE', '/<YOUR_PATH>/');
    7: define('SITE_ID_CURRENT_SITE', 1);
    8: define('BLOG_ID_CURRENT_SITE', 1);


    Thanks for the suggestion YossarianC.

    I checked the config file and all the code above is present.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Multisite crash after update’ is closed to new replies.