WordPress.org

Support

Support » Multisite » [Resolved] Multisite Comment issues

[Resolved] Multisite Comment issues

  • I recently upgraded my site myrddin.de to a multisite with subdomains on http://www.mmo-game.eu. I can post comments on http://www.mmo-game.eu, http://www.myrddin.de but oddly enough not on skyrim.mmo-game.eu

    Setup:

    • http://www.mmo-game.eu – mainpage
    • wildstar.mmo-game.eu – multisiteblog about an upcoming game
    • myrddin.mmo-game.eu -> domain mapping http://www.myrddin.de old site, imported
    • skyrim.mmo-game.eu – multisiteblog about another game

    When I try to post something on a subdomain the url shows: http://skyrim.mmo-game.eu/^http:/112.14.235.167/

    all subdomains have A records, so that can’t be it … any ideas?

    • movies.mmo-game.eu: movies.mmo-game.eu. A 85.214.41.8
    • myrddin.de: myrddin.de. A 85.214.41.8
    • skyrim.mmo-game.eu: skyrim.mmo-game.eu. A 85.214.41.8

    also the vhost.conf file includes

    ServerAlias *.mmo-game.eu *.myrddin.de

    This is on Centos using Plesk

Viewing 4 replies - 1 through 4 (of 4 total)
  • Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    When I try to post something on a subdomain the url shows: http://skyrim.mmo-game.eu/^http:/112.14.235.167/

    Go to Network admin -> Site and edit that site and check to see where it;s stuffing in that extra IP based URL.

    The IP (I changed the numbers a bit) appears to be my personal IP, not the Server IP. It does not appear when browsing the site, only when I hit “post”. It also appears to be a 404, page not found error.

    I checked the network settings about correct .htaccess, but it seems to be the correct settings.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    There are no errors in the error_log, or php log.

    Have you tried a different theme? Maybe there’s a function doing that…

    Hah, I thought it was a reqwrite issue, but could nto pin it down, until looking at the server configuration itself.

    To block no-referrer spam I added

    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*myrddin.de.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule ^(.*)$ ^http://%{REMOTE_ADDR}/$ [R=301,L]

    and ofc the mmo-game.eu domain was not in the list. Now I changed it into:

    # block comment spam by denying access to no-referrer requests
    RewriteCond %{HTTP_HOST} myrddin.de
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*myrddin.de.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule ^(.*)$ ^http://%{REMOTE_ADDR}/$ [R=301,L]
    
    RewriteCond %{HTTP_HOST} mmo-game.eu
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*mmo-game.eu.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule ^(.*)$ ^http://%{REMOTE_ADDR}/$ [R=301,L]

    and everything works fine.

    Thanks for taking your time to look at things. Maybe it will help someone else having thse issues aswell.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Multisite Comment issues’ is closed to new replies.
Skip to toolbar