Support » Networking WordPress » Multisite Child Theme Issues with Import URL

  • Resolved redleafloft



    I seem to be having the same problem as this user did when trying to activate a child theme on a multisite platform.

    I am using an ElegantTheme called “Divi”. When I activate the theme on the network site it works great. When I try to activate the child theme that I created, the page loads without any CSS styling. Here is the Import URL:

    @import url(‘../Divi/style.css’);

    Per the aforementioned user’s problem it looked like the fix Mika suggested was to do something in the .htaccess file to make it work. That seemed to be the trick, however the code that fixed it wasn’t explicit.

    I have less experience with .htaccess so I the beginner’s version of how to fix it. I understand that something about .htaccess makes multisite themes magically work – though I’m not at all sure what each line of code is doing. Here’s my .htaccess file:

    # To set your custom php.ini, add the following line to this file:
    # suphp_configpath /home/yourusername/path/to/php.ini
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress
Viewing 2 replies - 1 through 2 (of 2 total)
  • If that’s your whole .htaccess, then that isn’t it 🙂

    Have you tried:

    • flushing any caching plugins you might be running, as well as server and/or browser caches.
    • deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read “How to deactivate all plugins when you can’t log in to wp-admin” if you need help). Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old
    • switching to the Twenty Fourteen theme to rule out any theme-specific problems. If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twenty fourteen. That will force your site to use it.
    • manually upgrading. When all else fails, download a fresh copy of the file of WP (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first.

    That’s a relief, thanks for the confirmation. I did manage to get the page to load and everything looks great now. It turns out that you were right, this was the error:

    <usererror>clear cache</usererror>

    Thanks for your time!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Multisite Child Theme Issues with Import URL’ is closed to new replies.