Support » Networking WordPress » Multisite Built-In Domain Mapping Redirects to Signup/Registration

  • B1gJ4k3

    (@b1gj4k3)


    I’m running a multisite network with subdomain installs. I have two sub-sites, each with their own domain. Previously, I was using the WordPress MU Domain Mapping plugin and things were working fine. However, I then found out that WordPress 4.5+ supports domain mapping out of the box and wanted one less plugin to maintain, so I thought I’d give it a shot. I inactivated the plugin, removed sunrise and followed all the steps in the article linked above (created parked domains, changed the site URLs and set the cookie domain).

    However, when I try to visit the new URL, I just get redirected to http://mydomain.org/wp-signup.php?new=subdomain with the message “Registration has been disabled.”

    Any idea what would cause this? The only thing I could think of is that I set an A record for the parked domains for the unique IP address of the main site, but that shouldn’t really make a difference since it’s a parked site, right? I’m on Dreamhost if that makes any difference.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator bcworkz

    (@bcworkz)

    That’s right, A records all point to the same server IP. WP sorts out what to do based on the request. I have to think there is a conflict somewhere. The question is where? If your server is running Apache, make a backup copy of your installation’s .htaccess file. Then delete all rules in this file except for the rules within the WordPress comments. If you are on nginx, do whatever the equivalent is. I don’t have nginx experience, sorry.

    If that doesn’t help, restore from the backup you made. Next deactivate all plugins and network enable only the twentyseventeen theme to force all sites to this theme. Domain requests should now work. Restore the desired themes and plugins, one at a time. When domain requests again fail, the last activated module is causing a conflict.

    onomiko

    (@onomiko)

    I have the same question. Also on DreamHost. They refuse to discuss multisite so it’s frustrating.

    Trying to map http://www.examplesite.com/site1 to http://www.someothersite.com.

    My network works perfectly as subdirectories. When I enter the domain I want to use (not using the old mapping plugin but WP 4.9.8), the network site goes missing. Site not found.

    The network site domain is parked at DH. The main site & WP installation is at DH. I can’t figure out what’s gone off.

    This worked perfectly on the host I’m moving my installation from. I started fresh with a new WP installation because back in the day, I used sunrise.php, etc. to power my network. I’ve reviewed everything 100 times. Anyone have the clue I don’t?

    • This reply was modified 6 months ago by  onomiko.

    I’m also having this issue – did you by any chance figure out what was causing it?

    Yep. Dreamhost actively disallows Multisite in this way. They say you can install it if you want, which is great, but the installation will only work if you don’t try to assign each site its own domain. They frown upon that and won’t allow the domain name to do anything but remain parked.

    There was no way around it. I’d moved all my sites to Dreamhost because they advertised that Multisite was a-ok. So, rather than search for a new host and transfer everything all over again, I’ve had to hunker down and split all sites into separate installations on the host. For the tiny sites I run, this is super annoying as there are minor plugin updates to maintain every week across all sites. Just not a great situation. Sorry it wasn’t better news.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    That’s not an accurate understanding of how you can use Multisite with DreamPress.

    If you want to assign domains per site, it’s weird, but you want to ‘fully host’ the add-on domain with the Web Directory as the same of Main Domain.

    This also lets you use SSL properly.

    FWIW it’s equally weird with cPanel and mapped domains when you want to add SSL.

    Thanks Mika. No one had mentioned DreamPress here but it’s good that you jumped in. And it’s good to have this answer after working with multiple tech support reps over several weeks to finally uncover the reason multisite domain mapping wasn’t taking. None of the other reps knew either but they had just as many confident suggestions (including this one) that did not work.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.