WordPress.org

Support

Support » Multisite » Multisite and Yoast 301 Redirect Serving Raw HTML

Multisite and Yoast 301 Redirect Serving Raw HTML

  • Okay, I’ve been having issues with two multi-sites. One is theartisanjewelry.com and the other is organically.us. For this issue, I will use just theartisanjewelry.com information (they are both having the same problem).

    The main blog is on theartisanjewelry.com. I have a sub-blog, theartisanjewelry.com/home. On the sub blog, I run the wiki and provide metaphysical info. The system info is:

    ### Begin System Info ###

    Multi-site: Yes

    SITE_URL: http://theartisanjewelry.com
    HOME_URL: http://theartisanjewelry.com

    Jigoshop Version: 1.6.5
    WordPress Version: 3.5.1

    Platform: Windows
    Browser Name: Firefox
    Browser Version: 21.0
    User Agent String: Mozilla/5.0 (Windows NT 6.2; WOW
    64; rv:21.0) Gecko/20100101 Fire
    fox/21.0

    PHP Version: 5.3.13
    MySQL Version: 5.0.91-log
    Web Server Info: Apache/2

    PHP Memory Limit: 256M
    PHP Post Max Size: 20M

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 4 Status: Acceptable

    Show On Front: page
    Page On Front: 4813
    Page For Posts: 4798

    Session: Enabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /home/users/web/b2132/pow.parceledgardenscom/htdocs/cgi-bin/tmp
    Use Cookies: On
    Use Only Cookies: On

    UPLOAD_MAX_FILESIZE: 20MB
    POST_MAX_SIZE: 20MB
    WordPress Memory Limit: 64MB
    WP_DEBUG: Off
    DISPLAY ERRORS: On (1)
    FSOCKOPEN: Your server supports fsockopen.

    ACTIVE PLUGINS:

    Action Map: 1.8.1
    Akismet: 2.5.7
    Bad Ass Shortcodes: 2.0
    Base Plugin: 1.0
    Bootstrap Icons: 1.0
    Captcha: 3.5
    Easy Favicon: 1
    Google Analytics for WordPress: 4.3.3
    Grid Shortcodes: 1.2
    Jigoshop: 1.6.5
    Jigoshop for PageLines: 1.4.7
    Pagelines Customize: 1.1.1
    PageLines Googlefonts: 1.5
    Pagelines Sections: 1.0
    Simple CSS Lite: 1.4
    SOUP – Show Off Upcoming Posts: 1.7
    TinyMCE Advanced: 3.5.8
    WordPress.com Popular Posts: 2.6.0
    WordPress Importer: 0.6.1
    WordPress SEO: 1.4.7
    WP Keyword Link: 1.6.0

    CURRENT THEME:

    PageLines Framework: 2.4.2

    ### End System Info ###

    Now, the issue happens when I am on the main website, theartisanjewelry.com and then select either the home or the wiki page (pages on the sub-blog) which are managed with Yoast (WordPress SEO) 301 redirect to the sub-blog. It works on the local development just fine. However, when I select the page tabs on the live site, I get served raw HTML, as follows:

    0<!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
    <html><head>
    <title>301 Moved Permanently</title>
    </head><body>
    <h1>Moved Permanently</h1>
    <p>The document has moved here.</p>
    <p>Additionally, a 301 Moved Permanently
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    </body></html>
    HTTP/1.1 200 OK
    Date: Thu, 23 May 2013 04:01:06 GMT
    Content-Type: text/html; charset=UTF-8
    Content-Length: 78267
    Connection: keep-alive
    Server: Apache/2
    X-Powered-By: PHP/5.3.13
    X-Pingback: http://theartisanjewelry.com/home/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache

    <!DOCTYPE html>
    <html lang=”en-US” prefix=”og: http://ogp.me/ns#“>
    <head>
    <meta http-equiv=”Content-Type” content=”text/html; charset=UTF-8″ />

    <!– Site Crafted Using PageLines v2.4.2 – WordPress – HTML5 ( pro ) – http://www.PageLines.com –>

    <!– Title –>
    <title>Artisan Jewelry – Luxuriate Your Life</title>

    I have contacted the hosting company, PowWeb and have been going back and forth with them since 5/17/13. They deny it’s a server issue. I have redone the .htaccess files, I have deleted databases and reloaded info, deleted the website files and then re-upload them. I disabled the jetpack wp.me shortlinks and have attempted several other deletions of plugins excluding Yoast (WordPress SEO) because I cannot test if it works or not without the Yoast plugin.

    I’m at the end of my troubleshooting abilities.

  • The topic ‘Multisite and Yoast 301 Redirect Serving Raw HTML’ is closed to new replies.